collapse

Author Topic: Fixed my Marshall AVT20 combo  (Read 1227 times)

solderdripper

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 0
    • View Profile
Fixed my Marshall AVT20 combo
« on: September 09, 2017, 06:57:36 PM »
Not much of a question, just wanted to tell a little story:
I have a Marshall AVT20 "Valvestate 2000" combo, it has a 12AX7 preamp and TDA2050 IC power section, 10" speaker in a sealed enclosure. I think its really great, I love Marshall tone and this brings it in a small package. Replaced Celestion speaker with a Red Fang and liked that, too.

One day a few weeks ago I was goofing around and tried to run headphone-out to the input of my L5, and it killed the little AVT.  My guess is that using the guitar cord in the stereo headphone jack shorted the ring to ground, which fried the TDA2050 power amp.  I'm not sure exactly why; the headphone jack does have some components between it and the chip, but I guess they did not provide much of a load when the output was connected straight to ground. Error condition was a loud humming noise unaffected by any knob. The amp doesn't have any effects loop jacks, so I wasn't able to isolate preamp/power amp issues.  Then I discovered 22vDC at the speaker connectors. Checked some cap and resistor values in the headphone and power circuits, but I found no other damage. I ran out of ideas on what else to test so I went out on a limb and ordered some TDA2050s, couldn't get them from Digikey or Mouser but I actually bought ten for $8.61 on the big 'A' site. Ten was actually cheaper than buying two... They just arrived by slow boat, and the first one out of the package was good and fixed the amp. It was very easy to replace, its held on to a nice big heatsink by a metal clip. I put a sil-pad underneath it, its wide enough that it wraps up the sides of the chip, laying in the channel it fits in on the heatsink.

Now I have another amp online, and some TDAs to play with. Was thinking of making a modular amp, but that's another thread  :tu:

« Last Edit: September 09, 2017, 09:40:53 PM by solderdripper »

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Fixed my Marshall AVT20 combo
« Reply #1 on: September 10, 2017, 11:07:25 PM »
Glad you solved it  :dbtu:And welcome to the Foum  :cheesy:

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Info on Sunn Stinger 100 amp by Diablo_IV
[November 12, 2019, 10:35:53 AM]


Ibanez TSA30 - buzzing by phatt
[November 12, 2019, 08:52:26 AM]


Intermittent loud crackle from Fender Deluxe 112 Plus by traxcontrols
[November 09, 2019, 01:23:37 PM]


So you need a preamp - here are your options by flester
[November 07, 2019, 05:03:55 PM]


Burned up cap by Den.
[November 07, 2019, 03:43:24 PM]

* Sponsors