Welcome, Guest. Please login or register.

September 28, 2020, 02:08:12 PM

Login with username, password and session length

Recent Posts

 

Author Topic: Rocktron Rampage R80, have to switch on/off repeatedly to get sound  (Read 3522 times)

stormbringer

  • Master
  • ***
  • Posts: 95
  • Chip Points: 12
    • View Profile
Hey guys, my preamp project still on hold. :/ too much work for me with stuff for the band and the upcoming album release, a friend of mine though is in need of help. His Rocktron rampage SS amp is acting a little wierd. It takes numerous power cyclings to get running, the power led is on every time, but the sound is not. occasionally volume starts fading and the amp gets silent during play aswell.

I inspected the board, and everything looks fine, power resistor and all, entire board looks unheated in every way, electrolyte caps looks fine too, no bulging, although, i have no meter to check them. :/

Any hints on what to look for? there's not really much to the circuits in it, so i might just try and replace some stuff if somebody got a hunch here. :)

DrGonz78

  • Legendary
  • ******
  • Posts: 561
  • Chip Points: 69
    • View Profile
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #1 on: January 24, 2013, 01:10:46 AM »
The first thing I would do is download the schematic if you have not done so yet and get access to a meter. EDIT: I thought I found the Schematic but did not... Taking pictures of the inside of the amp can help you get advice where to check voltages if you do not know.

To me it sounds like the filter caps are not charging up correctly when powered on. I would solder up the joints on the main filter caps if you have not done so. Also, would be a good idea to check voltages before any soldering to see what we are getting at the PS and the filter caps. As all the wise ones have taught me over and over "Do not replace parts until you find the fault first". Words to live and die by...
« Last Edit: January 24, 2013, 01:14:48 AM by DrGonz78 »
“A person who never made a mistake never tried anything new.” -Albert Einstein

Roly

  • Legendary
  • ******
  • Posts: 2184
  • Chip Points: 288
    • View Profile
    • Australian Valve Amps
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #2 on: January 24, 2013, 01:27:54 AM »
Effects Send and Return on the back?  Headphone socket?  Contact cleaner or metho, then work a plug in and out.

Try injecting a signal into Fx Return and see if it comes on every time; if so then it's a dirty/oxidised switch contact in either Fx Send or Return (or maybe both).

If this gets no joy (or anyway) as Doc says check that the main supply voltage(s) is/are coming up okay at each switch on.
If you say theory and practice don't agree you haven't applied enough theory.

DrGonz78

  • Legendary
  • ******
  • Posts: 561
  • Chip Points: 69
    • View Profile
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #3 on: January 24, 2013, 01:50:36 AM »
Yeah I always forget to check those jacks and sockets...Thanks for looking out Roly :dbtu: So yeah check those out first. Hopefully it will be simple fix  8)
“A person who never made a mistake never tried anything new.” -Albert Einstein

stormbringer

  • Master
  • ***
  • Posts: 95
  • Chip Points: 12
    • View Profile
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #4 on: January 24, 2013, 04:09:32 PM »
Thanx guys, will tell him to drop by with the amp and i'll get going with some testing.

Roly

  • Legendary
  • ******
  • Posts: 2184
  • Chip Points: 288
    • View Profile
    • Australian Valve Amps
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #5 on: January 26, 2013, 02:21:55 AM »
Had a Roland Chorus one time that had been on a sea voyage, and all of the half-dozen sockets on the back were totally cactus.  Had a seaside keyboard where some of the fine tracks had actually been etched away and had to run wire bridges - sea air + electronics = pain.  :'(
If you say theory and practice don't agree you haven't applied enough theory.

bsantos

  • Chipper
  • *
  • Posts: 5
  • Chip Points: 0
    • View Profile
Re: Rocktron Rampage R80, have to switch on/off repeatedly to get sound
« Reply #6 on: June 22, 2020, 10:29:59 AM »
Hi @strombringer

Did you ever get to fix the issue?
I have exactly the same problem on my R80.

Also, did you find the schematics?

Thanks and regards,
Bruno