collapse

Author Topic: Modifying a First Act MA104  (Read 34593 times)

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Modifying a First Act MA104
« on: January 01, 2010, 04:01:01 AM »
Greetings all.

I have a First Act MA104 that I purchased from Wal-Mart years go when I first started playing guitar. I hated it's tone pretty quickly, as even with the gain knob all the way down, and the volume set very low, even vintage single coil pickups would send the amp into a nasty sounding breakup very quickly. When I found another amp (a Ross Systems 22) at a garage sale with a slightly better sounding distortion and the ability to clean up when the gain knob was turned down, the MA104 was shoved into a corner and forgotten about.

Fast forward to the present: The Ross 22 has since died and been cannibalized for parts and my main amp is a 100W Mesa/Boogie. The Mesa will remain my main performance and rehearsal amp for the foreseeable future, but a 100W all tube half-stack isn't very practical for bedroom practice, never mind the impracticality of lugging a big heavy head and cabinet across town twice a week for rehearsals. So the MA104 has been brought out of its corner and put to use again. Stock, it still sounds gross, but unlike years ago, I now own and know how to operate a soldering iron. :)

First Act wasn't forthcoming with a schematic, so I traced the circuit out and made my own in LTspice. It is attached. I'm pretty sure the diagram is complete, but I could have made some mistakes in tracing the circuit. So if anyone sees anything that doesn't make sense, please lemme know. Though the output chip is labeled "UTC2003", I'm pretty sure it is a TDA2003, which UTC makes. The power ratings and test circuit seem to be close to what's in the amp and First Act's claimed power output for this amp.

Thus far, I've made a few mods. I spliced a 1/4" plug onto the speaker out and used one of the 10" 40W 8Ohm speakers left over from the Ross 22. Overkill for a 4W amp, I know, but the 10" speaker sounds a lot better than the little 4" speaker it came stock with. With the help of the fellows at Music-Electronics-Forums, I lowered the gain in the 1st op amp stage. With the stock values, the gain of the 1st stage was over 300, enough for even a vintage single coil to overdrive the op amp hard against it's power rails. I changed R2 from 270Ohm to 1KOhm, and C4 from 10µ to 1µ. The gain knob has a much more usable range from clean to barely breaking up to full distortion now.

At this point I'm looking to achieve the following:
  • More clean headroom. Even when the gain knob is all the way down, when the volume knob is swept past 4, there starts to be a bit of breakup on the attack that I don't like. Past 4 on the volume knob, the amp stops getting louder as quickly and starts getting dirtier. Since the volume control is after the gain and tone controls, I'm guessing that the 2nd op amp stage is making the signal from the 1st stage too hot and it is overdriving the output chip. The voltage divider on the output of the 2nd stage barely attenuates the signal before it hits the output stage. I've got few ideas here:
    • Reduce the gain of the 2nd stage
    • change the voltage divider to attenuate the output of the 2nd stage more.
    • Reduce the gain of the output stage
    • A combination of all or some of the above

  • More highs. When I run the amp clean, I dime the tone control. When I turn up the distortion, I turn it down to tame some of the harshness that comes when the turning the gain up.That's all well and good, but when the tone control is dimed, it still isn't enough highs. The amount of highs with the tone control turned up is short of "pleasantly warm." I'd like it to be able to go all the way up to "sparkly bright", if possible. I wouldn't mind if it went a little bit into "piercingly bright", as I can always turn the tone knob down. I've got a few ideas here too:
    • Lower the value of or remove C3 in the 1st stage
    • Lower the value of C8 in the tone stack
    • Lower the value of or remove C13 in the 2nd stage
    • Some combination of the above

  • Tweak the distortion character of the amp. I want to do this after I have the above two addressed. I'd like to play with LEDs both as the hard clippers and in the negative feedback loop of the 1st stage as soft clippers, as I've discovered through modifying one of my pedals that I prefer the clipping sound made by LEDs to that of 1N4158s.

Hopefully all that isn't tl;dr. Your input on the above would be greatly appreciated.

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Modifying a First Act MA104
« Reply #1 on: January 01, 2010, 01:20:20 PM »
Hi Koreth.
Problem is, clearly the First Act designers made a little market research and found out that their average client would be a kid hooked on MTV (the old one that played music, including ACDC, ZZTop, Aerosmith, etc., not the new Disney Teen Channel type), had little or no $ to spend, wanted *that* rock sound, and bedroom volume level would be limited by Mom's patience.
So they built an excellent (for that purpose) distortion-pedal-straight-into-TDAsomething thing.
Great fun, but, what headroom?
*If* you have to replace speaker, preamp, power amp, cabinet and power supply, you are building a new amp.
If you only need a little more highs, replace C10 with a .0022uF cap, and solder a .022uF in series with a 1K resistor, across R10.
Anything beyond that merits a new amp.
What speaker does the First Act have?

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #2 on: January 01, 2010, 03:40:20 PM »
Stock, the MA104 comes with a tiny, 4" speaker of unknown manufacture.

I agree that replacing the power supply, preamp, power amp, and cabinet, I'm building a new amp. But that's not what I'm trying to achieve here. Thus far I've changed the speaker and replaced two components to give the gain knob a useful range. Hardly building a new amp, IMO. Now if I get to the point where I'm adding or removing op-amps in the preamp, changing the 2nd stage into a tonestack or something, replacing the power supply and changing the TDA2003 for something bigger, than yes I am building a new amp and would do better to start from scratch. But that's not what I want to do. What I want to do is reduce the output of the preamp slightly so it isn't overdriving the power amp, get some more highs and tweak the distortion character slightly. The latter I suspect I can do with a few dollars and a few minutes with my soldering iron. The former would require more parts, more time, more planning and knowing more than I do now to pull off successfully.

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Modifying a First Act MA104
« Reply #3 on: January 01, 2010, 11:18:38 PM »
Good, try those two mods I suggested.
The first one turns the "pedal" tone control more into an "amp" tone control; the second adds some more sparkle.
If you want to increase the amount of it, lower the series resistor to, say, 1K, and if you want ho boost some more high mids, double the capacitor; beyond that, you will get more hiss than useful sound.
Good luck.
PS: the single biggest "mod" would be, no joking, put a Jensen "Mod" there.
The 5" will very probably fit as-is; maybe you can use the 6", which is great; I doubt very much you can fit an 8" which would be killer.
Consider an 8" fits into a 22 cm circle but you should leave at least *some* wood around it.
The headroom brickwall that is stopping you is that *very* low powered TDA2003; any other, from TDA2006 up, would be in the ballpark of regular "Practice Amps".
Good luck.

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #4 on: January 02, 2010, 01:07:31 AM »
I was wondering about that TDA2003. Unless I'm misunderstanding things, I figure with 14V supply and a gain of 32 as it is currently configured, the hottest signal you could feed to it without breaking up would be in the neighborhood of 1.5Vrms. Basically, I could feed it directly with my guitar, and it would probably still breakup if I used the bridge pickup.

I took a look at the Jensen MOD series, nice. Unfortunately, there isn't even enough room to mount even the 5" speaker without building a new cabinet. A damn shame. I really like the sound of the 15W 6" version from the sound clips on the website.

phatt

  • Legendary
  • ******
  • Posts: 2036
  • Chip Points: 241
    • View Profile
Re: Modifying a First Act MA104
« Reply #5 on: January 02, 2010, 07:25:07 AM »
Hi koreth,
             I'm afraid there is little chance of *Clean* while you have Diodes (D2,D3) permanantly strapped across the signal path.
Try lifting them and see how it sounds ,that should give it more signal headroom.

For more brightness try lifting some of those caps that hang across the signal path as well. (try C12)
if TO Bright then half the value,, try 500pF.
I'm guessing but as JMF has noted this is just a TS9 type circuit with a speaker output.
Phil.
 

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #6 on: January 02, 2010, 01:14:33 PM »
While I would generally agree with that, until their forward voltage the diodes should do nothing. So the 1N4148s should have no effect on the signal until the signal coming out of the op amp reaches 1.3-to 1.4Vpp. The bridge humbucker on my guitar isn't that hot as is evidenced by there being no clipping with the gain knob is turned down until the volume knob (located after the clipping diodes) is turned up. As such I want to look at the gain of the output stage or the opamp before it. But I'll try lifting D2 and D3 to see if that makes a difference.

phatt

  • Legendary
  • ******
  • Posts: 2036
  • Chip Points: 241
    • View Profile
Re: Modifying a First Act MA104
« Reply #7 on: January 03, 2010, 07:14:21 AM »
Hi koreth,
           Just had another look at your circuit

Re "More clean headroom"
R2 is way to small,, try 2k ish for a more sane progressive gain.

Re "More highs"
C7 (after VR2) is also 5 mile to large, try 10nF.
that will get rid of the big hump at 100Hz.

Re "the distortion"
With or without diodes the trick is to setup the two opamp stages with just the right amount of *gain* then the amp will probably respond/sound ok.

It's debateable whether diode clipping sounds much better that just letting the signal slam into supply rails in a small amp like this,
Diodes or not you will have to tweak it.

BTW, you obviously have some kind of software setup which looks like it can simulate,,so why not run a few sims yourself and you will see this all happen.
Phil.

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #8 on: January 10, 2010, 04:31:12 PM »
I've done some more tweaking of the circuit. I first tried replacing C8 with a .01, thinking it would get me more highs. It did, slightly, but it didn't cure the muffled/muddy sound I'm still getting from the amp, and worse reduced the audible effect of sweeping the tone knob to almost nothing.

So I did some more reading and finally figured out how to use LTSpice to do more than just draw circuit diagrams. I made a schematic of just the tone stack starting at C7 and ending at the wiper of VR3, then did an AC analysis with sweeps for a few different positions of the wiper of VR3 to see just what the heck the tone stack is doing. I'm actually amazed by its simplicity. At one end of VR3's sweep the tone stack is a simple high cut filter. At the other end, it is a notch filter with the notch gradually shifting forward flattening out to smoothly transition into the high-cut filter. Thinking about how I run my EQ's on the other amp, it actually makes sense. Clean sounds tend to have a mid-range scoop to counter the mid-range emphasis that magnetic pickups supposedly have for a more natural, balanced sound. But when running heavy distortion, I tend to pull my highs back a bit to keep the distortion from sounding too harsh. So yeah, once again, the First Act designers knew exactly what they were doing.

By changing C8 to the same value as C10, I pretty much flattened out the mid-range notch. All lows and mids with rolled off highs sounds pretty muffled. Playing with a few values in the simulation I found out I actually want C8 to be a larger value than C10. Yes, a larger C8 rolls off more highs, but the greater the difference, the notch gets narrower and shifts it down in the frequency range. There are other places in the circuit I can get my highs back or reduce lows to keep the amp from sounding muffled. Also, changing C7 to a smaller value has a negligable (<-3dB) on the bass until the cap gets down into the .1µF range and lower. If I change C5 and C7 to 1µ, I get the bass down about -1.5 dB. I think I'd have to change C15 and C24 to 1µF to as well to see a -3dB reduction in bass. It'd be easier to change the input caps at each gain stage from .022µF to .01µF, methinks. So I'm not going to bother with C7 just yet. I'll play around with the values of C8, C10 and R7 in the simulation and see if I can't tweak the tone stack to my liking in the simulation, then I'll try it and report my findings.

Yes, I know I'm wasting my time. This is a fun learning experience.

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #9 on: January 11, 2010, 01:57:16 AM »
Success.  :)

C8 is now .047µF, and C10 is .0022µF. According to the simulation, this produces a notch -14dB down at about 330hz and spreading two octaves from center with the tone knob on 10. Perhaps not ideal, but it definitely gives the tone knob a usable sweep. I ran some more simulations and found that with C8 at .1µF, C10 at .001µF, and R7 at 6.8K (which I think is a standard value) I could make the tone knob approximate a Fender tone stack with the mid knob set at 2. I'm not sure how much more I want to play with the tonestack without changing to a better speaker.

Either way, the amp sounds much better and useful now.

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #10 on: February 07, 2010, 11:20:11 PM »
So I figured out a few more things with LTSpice, and even found enough models of parts used in the MA104 for a simulation of the whole amp to run. Yay!  :) Thus, I have spent most of my weekend making tweaks to circuit in the simulator and staring in fascination at pretty colored graphs of the resultant waveforms and voltages in various parts of the amp's circuit. Good times. I also redrew the old schematic, because it was a pain to try to follow. The new one is attached. I didn't draw out the output stage because I can't find a model for the TDA2003 and the arcane art of making models from scratch is still beyond my ken.

I made a few discoveries. Unless the 4558 model made by Texas Instruments is innaccurate, the 4558 can't swing all the way to it's voltage rails, it clips hard about 2V before them. I was tempted to blame the model first, but when I tried other opamp models that came with LTSPice, they did the same thing, clipping hard a volt or two before hitting the power rails. So I guess it is a behavior of op amps. I didn't know op amps did that, but it is a good thing to know.

However there's been some differences between the simulation results and the results of plugging a guitar in and playing the amp that are puzzling me. According to the simulation, with the gain, volume and tone knobs cranked, the highest voltage swing that could happen at the preamp's output is about 350mVpeak. The TDA2003's gain is presently set to 10, and it is getting about 13V from the power supply. So, unless I'm Doing It Wrong, a 700mV peak to peak times a gain of 10, means the TDA2003 should have a signal of about 7V peak to peak on it's output, well below it's power rails, and shouldn't be clipping, ever. However, when I plug in my guitar and strum as hard as I can, I can hear a bit of breakup on the attack with the gain knob set at 3.

Now, my big 100W tube amp has it's input stage biased at 1.5V. So the hottest signal my guitar could possibly put out without overdriving the input stage and giving me dirt on the clean channel (which it doesn't) is 1.5Vp. I doubt even the bridge pickup puts out that hot a signal. Now in my simulation, a 1.5v signal with the gain knob set at 3 doesn't even cause the opamp to clip. The clipper diodes have been lifted from the circuit for now, the 2nd opamp is set at unity gain, and the TDA2003 is set to a gain of 10. So where the heck is this distortion coming from?  >:(

Some thoughts. My simulation is wrong? (likely). If that's so, I'm not sure where to start looking. Maybe I have the taper of the gain pot set wrong? (i.e. What LTSPice thinks is 70% rotation is actually 30% on the pot itself). The TDA2003's gain is set too low and the chip is unstable? (maybe?) The chip gets warm enough to feel that it's warm when the amp is running, but it doesn't get HOT like I've read about in these forums when a chip oscillates. The datasheet specs a minimum closed loop gain of 92.3, but stock, gain was 32.1, I don't think it had any problems being set that low.

I wish I could find my multimeter and take some measurements, instead of making blind guesses like this. An oscilloscope would be nice too.

I suspect those of you who know what you're doing and know how to use SPICE are probably rolling your eyes about now. Fair enough. But your input would be appreciated.

Koreth

  • Regular
  • **
  • Posts: 19
  • Chip Points: 2
    • View Profile
Re: Modifying a First Act MA104
« Reply #11 on: February 08, 2010, 01:01:47 AM »
Let the record show that I am blind. My multimeter was sitting on the shelf where I last placed it all along. I just hadn't stared at the exact spot it was sitting hard enough.

I took a measurment of the gain pot. Let the record also show that I am an idiot. The taper in the simulation was way wrong.

An oscilloscope would still be useful to have.
« Last Edit: February 08, 2010, 02:41:01 AM by Koreth »

rowdy_riemer

  • Elite
  • ****
  • Posts: 264
  • Chip Points: 13
    • View Profile
    • www.riemer.us
Re: Modifying a First Act MA104
« Reply #12 on: February 08, 2010, 12:47:06 PM »
Get a $50 osciloscope. Check out this post on diystompboxes.com: http://www.diystompboxes.com/wpress/?p=96

Thebighat99

  • Chipper
  • *
  • Posts: 2
  • Chip Points: 0
    • View Profile
Re: Modifying a First Act MA104
« Reply #13 on: March 02, 2010, 05:43:00 AM »
For some reason I cant get your schematic to display. It keeps saying the file is corrupted. Would you please post it again or give me a link where I could get a copy. I have this amp and was also thinking of trying some modding. schematics would be a great help thanks.

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Modifying a First Act MA104
« Reply #14 on: March 02, 2010, 10:31:31 AM »
Me neither can open it, although I did a month ago.
Dear Koreth, please repost the schematic.
Thanks.

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

The Dangers of Speaker Impedance Mismatching by phatt
[Today at 03:28:27 AM]


Gallien Kruger GT200 by gbono
[December 04, 2019, 02:54:12 PM]


Eight Audio Kit TDA7294 and TDA2050 from India by Jazz P Bass
[December 04, 2019, 09:45:34 AM]


Peavey Classic VT by Enzo
[December 02, 2019, 09:16:10 PM]


So you need a preamp - here are your options by flester
[November 29, 2019, 05:44:46 AM]

* Sponsors