Welcome, Guest. Please login or register.

October 20, 2020, 02:06:00 AM

Login with username, password and session length

Recent Posts

 

Author Topic: Roland JC-120 with weak reverb  (Read 773 times)

KattMat

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 1
    • View Profile
Roland JC-120 with weak reverb
« on: September 18, 2020, 01:12:30 PM »
Greetings! Registered to the forum as it looked like the right place to get some pointers about this excellent amp that I recently got my hands on.

It's a Roland JC-120 which I believe to be a gen 4 (main ins, chorus trim on the back). Pretty busted up but got a good deal on in. The reverb-pot was totaly broken so had to change that. It's got the QC Elec. "Folded Line" reverb tank (the one manufactured by beautiful girls :)) that's confirmed working (impedance tests ok, also able to drive it from other sources).

The problem is that the reverb is well....really weak. If I turn the reverb knob to max and play some guitar into it I can hear the reverb but REALLY quietly. It's there but just barely. If I however bang the amp or the tank I get some big loud spring wobblyness. I've gathered from this that the return part seems to be just fine and that the issue seems to be with whats driving the reverb. I've checked the leads but I'm beginning to suspect that it's an IC that's busted. But I really don't know how to check for that other than starting to blindly replace ICs in the reverb section, which I'm not that keen on. 

I've worked on tube amps before but I'm really a novice when it comes to SS. Would really appreciate any input or pointers about this issue as I LOVE the amp!

DrGonz78

  • Legendary
  • ******
  • Posts: 562
  • Chip Points: 69
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #1 on: September 18, 2020, 02:33:32 PM »
What is the serial number on the amp? I ask only that we can first help identify the correct schematic to use.
“A person who never made a mistake never tried anything new.” -Albert Einstein

KattMat

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 1
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #2 on: September 18, 2020, 03:03:08 PM »
Serial is 901576
220V model

I've been using this one for troubleshooting:
http://guitar-fx-layouts.42897.x6.nabble.com/file/n46737/JC_120_Schematic.png

Not positive it's the right one but it mostly seems to check out
« Last Edit: September 18, 2020, 03:09:21 PM by KattMat »

Jazz P Bass

  • Elite
  • ****
  • Posts: 223
  • Chip Points: 18
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #3 on: September 19, 2020, 12:45:40 AM »
A TA-7200 P 10 watt power amplifier is used to drive the reverb pan.
It appears to be a 1.1 Vac output signal on the schematic.
Measure it and see what you have.

KattMat

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 1
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #4 on: September 19, 2020, 09:16:57 AM »
Thanks for the suggestion!
I checked before but re-checked it now. Can't pick up any DC or AC at R96 with the tank connected. 

With the tank disconnected I get about 10Vdc that immediately starts dropping.
It reaches 3V after about 10sec of measuring and then starts jumping around between 0 and 3V.

What do you think? Faulty cap somewhere?
« Last Edit: September 19, 2020, 09:40:15 AM by KattMat »

g1

  • Legendary
  • ******
  • Posts: 661
  • Chip Points: 79
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #5 on: September 22, 2020, 12:07:19 PM »
You can't measure DC there as it is blocked by the cap.
The volume control determines the send to the reverb IC, so if you had the volume turned down there will be no AC voltage at the tank.
Check what is getting to the input of the reverb drive IC (IC1).
From what is shown on the schematic, they have 22mVAC signal at the input jack.  Then the volume control is adjusted til there is approx. 30mV at the wiper.  Under those conditions there should be approx. 20mV at pin 10 of IC1, and 1VAC at pin 2.

KattMat

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 1
    • View Profile
Re: Roland JC-120 with weak reverb
« Reply #6 on: October 01, 2020, 12:23:05 PM »
-SOLVED-

Thanks for the suggestions!
Had no way of measuring mVOLTS with my multimeter so I sprung for a replacement accutronics tank (8AB2D1A).
Turns out the old tank was the weak link. The replacement works and sounds great!