Welcome, Guest. Please login or register.

September 28, 2020, 01:54:24 PM

Login with username, password and session length

Recent Posts

 

Author Topic: LabSeries L11 power section repairs & spares  (Read 1006 times)

SwamiRob

  • Chipper
  • *
  • Posts: 7
  • Chip Points: 0
    • View Profile
LabSeries L11 power section repairs & spares
« on: July 20, 2020, 10:48:42 AM »
I've picked up a pretty battered L11 off eBay that I'm trying to get working for some electric piano. Was working ok other then the odd little sputter when I first got it (it was listed as probably needing a good service), when giving the thing a good clean out previous to it the reverb send/return socket has all the pins snapped off, and the reverb tank has a hook kissing off the transducer. Other then that it seemed to be able to get some decent volume without any problems other then the little random bits of noise that kept coming out that I figured could also be dirty pots. Second time I plugged it in to a 4ohm bass cab totally forgetting that it's 8ohm. Didn't use much volume but this time it sounded awful at anything other then minimal volume (until I worked out what I'd done...) making a horrendous farting noise. Same deal when I unplugged it and went it into a 8ohm speaker.

Not sure if the filter caps were ready to fail anyway and that's put them over the edge, or I've messed up some other element of the power section? Never ran an amp on the wrong impedance and don't know much about what it can damage, didn't think at all at the time as I'm so used to SS stuff being rated for at least as low as 4ohms.

I think I remember seeing that some obscure company makes output chips that are compatible with these (although my limited knowledge of output chips is that they tend to blow as quickly as a fuse and not gradually fail), but I'm a little concerned that there could be alot of components that are t going to be very easy to replace.

As a little aside if this ever gets revived to working condition - can anyone tell me a bit more about the compressor? The -/+ sides of it, is the plus side an upwards compression sort of effect/a downward expander/both/neither?

Enzo

  • Legendary
  • ******
  • Posts: 1977
  • Chip Points: 214
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #1 on: July 20, 2020, 01:27:06 PM »
Schematic please.

Jazz P Bass

  • Elite
  • ****
  • Posts: 218
  • Chip Points: 18
    • View Profile

Enzo

  • Legendary
  • ******
  • Posts: 1977
  • Chip Points: 214
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #3 on: July 20, 2020, 05:18:35 PM »
Don't read too much into it.  A 4 ohm load on an 8 ohm rated amp won't automatically blow it up.  The poor thing will run out of gas if you push it, but polite play won't hurt.

Also, the load impedance will have no effect on the filter caps.

The compressor is basically just a compressor, the control is not a compression level or "amount" control.  The compressor control is the threshold.

SwamiRob

  • Chipper
  • *
  • Posts: 7
  • Chip Points: 0
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #4 on: July 21, 2020, 06:13:30 AM »
Cool, thanks for that guys. Is there any other suspect parts that could be causing the noise I mentioned? The best way I could describe it is almost like a  It's very much seems to be related to how much the power section is trying to output. How hard the preamp is driving it, and the preamp overall is fine. Tested that by digging in and messing with the channel volume and the preamp output (which seems to have a very very weak signal or something isn't quite right with that either? The preamp seemed to be sending enough to drive the power section the 1st time I used it because the volume control unsurprisingly had an absolute ton of headroom).

*Before I've even posted edit* I've just went upstairs to power it up to refresh my memory on the sort of noise it was making and it's fine! A few random crackles again which I put down to the pots and stuff (maybe?) but no evidence of it at all now. Strange! I was doing a bit of soldering to try and get that old reverb socket out so don't know if something had stayed very hot and sounded horrible as a result? Not sure! Anyway just tested with a bass and no problems! Sounds ace. Definitely still getting it a full service however!

Just out of interest however. How worried should I be about the filter caps if I was to remove them to get at the poweramp? I know they're not things to be treated carelessly but I'm worried about any stored charge and generally removing them and screwing them back in again! There's no way I can get at this reverb socket properly without moving them.

Thanks again!

phatt

  • Legendary
  • ******
  • Posts: 2135
  • Chip Points: 261
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #5 on: July 21, 2020, 08:44:18 PM »
If the Amp has an Effects loop or Preamp out/Poweramp input then just bridge with a guitar cable.
That will bypass the internal switch in the amp.
If the amp then gives no trouble You have 2 choices,
1/replace the socket with the dodgy switch. (in some amps that can be a lot of work).
Or 2/ leave a short jumper lead inserted and forget about pulling the amp apart.
I'm sure you would rather be playing guitar than working on circuits.
The internal Sw in FX loop and like interconnects is so common that it should be the first thing you check when you have intermittent signal drop out.
If I had a dollar for every time I've answered these,, I'd be rich.
Back in the 50's these switched sockets were made to a high standard with pressed in silver contact  buttons now all you get is a strip of tin for a switch. Yes and most all big name gear now uses these crappy sub standard contacts so they don't take long to fail.
Phil.
« Last Edit: July 21, 2020, 08:49:35 PM by phatt »

SwamiRob

  • Chipper
  • *
  • Posts: 7
  • Chip Points: 0
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #6 on: July 22, 2020, 06:00:40 PM »
Awesome, will give that a go. Are these filter caps likely to be on my death certificate of I unscrew them? And if I do how much of a pain are they to get back in? Also is it worth going over everything with a soldering iron for dry joints etc, or is it not worth it if there's no obvious reason to do so even if the thing is a little old?

phatt

  • Legendary
  • ******
  • Posts: 2135
  • Chip Points: 261
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #7 on: July 24, 2020, 02:11:37 AM »
Keep it Simple,, just fix what is failing FIRST,,,, then move onto other things. 8|
If you have the amp open and there are no obvious signs of corrosion or Leakey El caps then job is done.

Unless these things have sat for years in wet damp storage and full of roaches and rat poo then the rule is simple,, if it ain't broke don't fix it.
Yes visual inspection of solder joints is a good idea but don't replace parts unless they are causing failures.
No need to get too concerned about cap voltages as Most SS power supplies are likely much lower voltage that Valve amps. (if that is the worry)
If the amp runs on +40/-40 then the caps will be rated at 50VDC.
Some big SS power amps run on much higher DC rails and they can be dangerous.
ALWAYS pull Power Cord from wall when working on circuits,, don't just rely on the wall switch.

If you are concerned then just measure the caps with your meter to check they have bleed off the supply before working on the circuit.
The human body can handle up to around 80Volts but after that you have to be very aware of the danger.
Phil.

SwamiRob

  • Chipper
  • *
  • Posts: 7
  • Chip Points: 0
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #8 on: July 24, 2020, 07:59:25 AM »
Awesome, glad to hear I don't have to do any more rooting around in there! Was enough of a task to clean the casings up, very dusty and gimey! Will check the pots to see if they're scratchy and clean them when it's next open if needed, because that's obviously a little bit more straightforward!

Yeah it was my concern that they may hold similar voltage, given their placement & size I assumed they fulfilled a similar role to power valves but wasn't too sure. Would I just measure whether they've bled or not across the screws, is it that straightforward? Need to get a ohmmeter first to be honest as I don't own one yet! Not sure I've used one since secondary school... They're rated on the parts list as being 3000uf 100v, but I don't know if parts are overspecced in that regard, because I know next to nothing about power amps or supplies.

Thanks again!

On another anxious note, the thing is apparently set up for 230v, with mains in the UK being 240v, will that matter much at all? Slightly less concerning, is the thing has a fan as well as a heatsink, assumably at lower volumes this being connected won't matter from a cooling perspective (it's so stupidly bloud I very much doubt it'll get used anywhere near the top of its headroom). But if it's taken out the circuit will it affect anything else to do with the power section, or will it simply be drawing less power?
« Last Edit: July 24, 2020, 08:16:31 AM by SwamiRob »

phatt

  • Legendary
  • ******
  • Posts: 2135
  • Chip Points: 261
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #9 on: July 27, 2020, 08:59:49 PM »
Yes just measure the DCV on the terminals of the caps.
The mains voltage is unlikely to cause an issue as it's only ~10% difference.
The fan is likely a backup for cooling at high power so again it's not important unless it's part of an over load & temp circuit cut out system. (maybe check the schematic)
Fans are cheaper than alloy so some later amp designs do rely heavily on fans for cooling (cost cutting is the aim for big companies now which trumps intelligent quality designs) but I'm guessing this amp being older already has a substantial heat sink.
Phil.

SwamiRob

  • Chipper
  • *
  • Posts: 7
  • Chip Points: 0
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #10 on: July 29, 2020, 12:30:10 PM »
Awesome thanks again, it most certainly has a substantial heatsink too, I've been told/have read in many places that they were pretty well made bits of gear.

I did try the patching solution by the way, it doesn't seem to solve the weird noise issue, and it seems to be quite intermittent still. However it does seem to result in a slight volume & clarity boost (I tried to volume match and it seems to sound nicer with it in. Did try it a little bit earlier and this horrible noise seems to occur when going direct into the power amp with a signal hot enough to drive it properly.

Gonna have a bit more of a look when I'm off night shifts from tomorrow morning. And gonna see if I can't get this bloody reverb working!
« Last Edit: July 29, 2020, 05:26:07 PM by SwamiRob »

phatt

  • Legendary
  • ******
  • Posts: 2135
  • Chip Points: 261
    • View Profile
Re: LabSeries L11 power section repairs & spares
« Reply #11 on: July 31, 2020, 06:45:03 AM »
OK sounds like there is a fault in the power stages.
Get a stick (Kebab skewers are ideal)  :tu:
Start tapping around the power supply and pwr amp section. Do this while passing a signal into the poweramp input. The idea is to try and isolate where the fault might be on the PCB.
You can also take the expert advice from *Enzo*,, just bang on the lid a few times and see if you can recreate the fault. :lmao:
Could be a cracked solder joint which can be a real pain to track down. Strong sunlight and a Magnifying  glass will help find what is often a tiny line on a track or solder joint. Larger parts are the most obvious places to look as they can vibrate and crack solder.
Those type of intermittent problems arise when big signals cause the crack to momentarily open causing a big crackle through the speaker.

I did once have an amp with a bad audio crackle on big signals,, turned out to be a failing contact in the power switch. Drove me nuts for a while. :duh

Still could be corrosion on the power amp input socket.
If it's the standard 6.6mm type then try a can of contact cleaner, spray into socket then insert the plug many times to clean the contact surfaces.
Phil.