Welcome, Guest. Please login or register.

August 11, 2020, 12:01:00 AM

Login with username, password and session length

Recent Posts

 

Author Topic: Altec 770 Biamplifier  (Read 2197 times)

gbono

  • Elite
  • ****
  • Posts: 277
  • Chip Points: 7
    • View Profile
Altec 770 Biamplifier
« on: July 07, 2020, 07:39:10 PM »
I have several Altec 770/771 biamplifiers that have been rebuilt but have an issue with excessive heating at idle. The schematics are for the 770 version but the design is the same for the 771.

The problem is that the heat ink will get up to 125F/50C when the amps are idling with no input and 8 ohm loads attached. I have tested many of these amps and they appear to operate in class AB and usually don't have this issue. The amps that I have now all meet their output specifications and play program very well but get hot. I replaced the zeners on the EB of the output transistors, cleaned and reapplied new heatsink compound to the mica insulators and checked the "stabistors" (CR1/2).

Can the amp run in class A?
« Last Edit: July 07, 2020, 07:40:41 PM by gbono »

Enzo

  • Legendary
  • ******
  • Posts: 1961
  • Chip Points: 212
    • View Profile
Re: Altec 770 Biamplifier
« Reply #1 on: July 07, 2020, 07:52:35 PM »
So what happened when you turned down the bias?

gbono

  • Elite
  • ****
  • Posts: 277
  • Chip Points: 7
    • View Profile
Re: Altec 770 Biamplifier
« Reply #2 on: July 09, 2020, 04:00:09 PM »
Opps I had switched out the HF/LF boards with another amp and the bias pots were turned up. THX Enzo. BTW the bias is supposed to be set using voltage across the EB of the output transistors (Q1/3?)- the spec setting is 17mV?

Enzo

  • Legendary
  • ******
  • Posts: 1961
  • Chip Points: 212
    • View Profile
Re: Altec 770 Biamplifier
« Reply #3 on: July 09, 2020, 10:11:01 PM »
I wouldn't think so, maybe across R3 or R4.  Personally I do it by looking at crossover distortion.  Star at the coldest setting, apply a sine wave and watch it on the output.  Now advance the bias until the crossover notch JUST disappears.  Most adjustments by the current spec will be a little warmer than this.  I like it though.

Remember it was getting hot just idling?  That means it is turning power into heat.  SO a quick and dirty close enough method is to monitor mains current draw of the unit.  Start at coldest setting and start advancing the bias control.  At first the mains current stays low.  At some point (in fact, the point the crossover notch goes away) of a sudden, mains current starts to rise with the bias adjustment.  At that point, stop and back off ever so slightly.

people will make arguments for one way or another, but these methods will get you close enough.