Welcome, Guest. Please login or register.

February 24, 2020, 09:36:01 AM

Login with username, password and session length

Recent Posts

Author Topic: JC 120 Powerup Farting/Discharge Sound  (Read 380 times)

Feesh

  • Chipper
  • *
  • Posts: 1
  • Chip Points: 0
    • View Profile
JC 120 Powerup Farting/Discharge Sound
« on: September 23, 2019, 07:39:34 AM »
Hey guys!

So ive recently inherited my dads 1981 Rolland JC120, and it still has the same "problem" i remember it having 20 years ago when i was growing up at home.

Whenever the amp is turned on, after about 5 seconds it emits this tearing/farting/electrical discharge like sound which is unaffected by any of the controls on the amp.  The sound is louder the longer the amp has been sitting idle.   Repeatedly turning on and off the amp produces a VERY quiet version of it.

Other than that the amp sounds great at all volumes/functions!  Only other problem ive ever had is the analogue reverb unit's springs being dislodged while carting it around to gigs.

I also took it to a reputable guitar tech (just the guts) and he did a general service but said nothing of this sound which i enquired about.

Any ideas are much appreciated!

Ill get to uploading a video tomorrow when i can get a good video/sound.

PMc

  • Regular
  • **
  • Posts: 17
  • Chip Points: 0
    • View Profile
Re: JC 120 Powerup Farting/Discharge Sound
« Reply #1 on: September 23, 2019, 06:33:14 PM »
From your description, sounds like a bad capacitor somewhere.

Sent from my SM-T560NU using Tapatalk