collapse

Author Topic: MaxTurbo mods  (Read 170 times)

phatt

  • Legendary
  • ******
  • Posts: 2029
  • Chip Points: 239
    • View Profile
MaxTurbo mods
« on: June 19, 2019, 09:24:04 PM »
I picked this up cheap and took the chance it might be an easy fix but proved to be quite a task.
It worked but had very low output for the claimed 40~50Watts. more like 10Watt :duh
Obviously a no name import job but as it was a small 10Inch speaker, just the size I was looking for as a small grab and go amp.

It says *RSGA5010R* on the front and a small badge on the grill that says *Max Turbo*
I only found one small reference to it on the net giving the specs but nothing more.
Power chip is TDA7295 and runs on +/-40volt rails.
I doubt there would be many of these around but if you have one it's likely got the same design problems so if you need all the mods I did to get it working I'll up load the schematic of all the mods.
meantime I've traced the main preamp circuit and added the main mod that fixed the notch filter issue.

It took a while to work out the circuit because double sided PCB's are a royal PITA to back track.  :grr
I'm sure I will have missed something but these schematics will be fairly close. I've tried to label the part numbers as found on pcb.
I have not drawn up the power section as it seems like it's taken from the data sheets of TDA7295.

After a while I found some of the missing power was due to a bent pin of an IC that was never soldered. Wooden chop sticks are a great fault finding tool when you
probe around. ;)

Improved power but winding the treble up past 3/4 invoked some really harsh hi freq distortion more like a crackle which was evident from the start but now even moreso.

Along with the bass treble there is a notch filter knob but it did not seem to work in any meaningful way.
So I finished drawing out the schematic (after many attempts) and simulated the circuit.
And sure enough just as my ears had noted, that Notch filter network seemed to have little effect on the tone shaping.

Up shot,, U5 (which is what the notch control pot connects to) seems to make no sense.
Be aware I'm still not sure how this circuit is *supposed to work* so I'm guessing a lot here. :-[ :-\
After many sims I took a gamble and connected the *top of VR5b* to the *input of U7* via a 10k resistor and Bingo the notch sweeped and worked as I would expect and
the bonus was that horrible treble issue was gone.  :) :)

The cab is cheap compressed cardboard crap so keep it away from water and it should be ok.
This thing had 10 miles toooo much bass so I replaced most of interstage 100nF caps with 10nF which made the amp usable at full volume.
I plugged the ports on the front which also helped the sonic result.

As I had a short Reverb tank laying around doing nothing so added a Reverb circuit between preout and power in,, a nice addition. 8)
The send return on the front is useless as it only works on the clean selection so when OD is engaged the FX loop is bypassed. WTF???
I'm stuffed as to why they made it so, maybe another design stuff up??
Phil.











galaxiex

  • Legendary
  • ******
  • Posts: 518
  • Chip Points: 46
    • View Profile
Re: MaxTurbo mods
« Reply #1 on: June 19, 2019, 10:57:59 PM »
Nice work phatt!  8)

Never know when someone might need/want that info.

Thanks for documenting!
Fear leads to Anger, Anger leads to Hate, Hate leads to Suffering.

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Z-MATCHER 100W IMPEDANCE MATCHER by Loudthud
[September 16, 2019, 04:42:44 PM]


Hybrid valve and TPA311x by jfetter
[September 13, 2019, 03:29:50 PM]


Marshall 5010 Needs Help by Jazz P Bass
[September 13, 2019, 12:12:27 AM]


Do you need a low pass filter in your amp when you already have the eq? by slimjohnny
[September 11, 2019, 06:01:57 AM]


Gallien Kruger GT200 by mandu
[September 10, 2019, 06:31:10 AM]

* Sponsors