collapse

Author Topic: Fixing oscillating sound in Johnson warrior 15 standard guitar amp  (Read 66 times)

thejedi

  • Chipper
  • *
  • Posts: 1
  • Chip Points: 0
    • View Profile
Hello! I'm new here... sorry for being ignorant and newbie

I have an old Johnson Warrior 15 guitar amp that does not output my guitar sound. Instead, when I turn it on, it makes ever lasting oscillations (boop boop boop boop boop...). I heard the right term is "motor-boating" but I'm not sure. Anyways, it makes no other sound but the (boop boop..) when I plug in my guitar.
It's a solid state amp, 15w. I tried looking for schematics online but couldn't find anything. I tested the speaker itself and it works just fine. Another peculiar thing is that if I plug headphones to the headphones jack, I can here my guitar in my headphones. Another thing is that when I bypassed the transformer and connected DC current, it still occured, though the sound changed a bit.
 
Any ideas?
I'll provide more information if needed

phatt

  • Legendary
  • ******
  • Posts: 2023
  • Chip Points: 239
    • View Profile
Re: Fixing oscillating sound in Johnson warrior 15 standard guitar amp
« Reply #1 on: August 24, 2019, 10:03:38 AM »
If you bypassed the Mains transformer and you are STILL ALIVE to talk about it then consider yourself very VERY lucky.
NEVER bypass the transformer of an amplifier. :trouble :trouble :trouble :trouble

I doubt the amp has been as lucky as you,, as the much higher voltage would have most likely destroyed the circuit and likely not worth fixing. :'(

I'd advise you to get help from a qualified tech shop to check out if it's worth fixing.
Phil.
« Last Edit: August 24, 2019, 10:05:41 AM by phatt »

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Google ReCaptcha-2 was broken! by Kathryntus
[August 24, 2019, 10:48:02 PM]


Fixing oscillating sound in Johnson warrior 15 standard guitar amp by phatt
[August 24, 2019, 10:03:38 AM]


Very loud humm from an amp - please help me fix it by phatt
[August 23, 2019, 11:30:26 PM]


Google ReCaptcha-2 was broken! by Kathryntus
[August 23, 2019, 01:15:58 PM]


Google ReCaptcha-2 was broken! by Kathryntus
[August 22, 2019, 07:56:31 PM]

* Sponsors