Solid State Guitar Amp Forum | DIY Guitar Amplifiers

Please login or register.

Login with username, password and session length
Advanced search  

News:

SSGuitar has moved to PHP 7.1, enjoy the speed!

collapse
Pages: [1]   Go Down

Author Topic: My amp cracks when I....  (Read 2072 times)

dissman

  • Chipper
  • *
  • Chip Points: 0
  • Posts: 2
    • View Profile
My amp cracks when I....
« on: February 24, 2010, 09:30:02 AM »

When I twist or move my cable (male end that is in the amp) I get a cracking noise that tends to go on for quite some time. In addition, the sound sometimes drops for periods of time. Anyone have any suggestions on fixing?
Logged

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Chip Points: 427
  • Posts: 4143
    • View Profile
Re: My amp cracks when I....
« Reply #1 on: February 24, 2010, 12:24:11 PM »

1) Squirt a little contact cleaner into the jack and work the plug in/out a few times to remove grime
2)Use another cable
3) resolder the jack contacts which may be cracked
Logged

dissman

  • Chipper
  • *
  • Chip Points: 0
  • Posts: 2
    • View Profile
Re: My amp cracks when I....
« Reply #2 on: February 24, 2010, 05:13:02 PM »

I will try those options. Cable isn't the problem. Thanks.
Logged
Pages: [1]   Go Up
 

* User Controls
 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
* Recent Posts
Peavey Filter Caps by Tennerondack
[Today at 09:57:41 AM]


HH IC100L schematic anyone? by maxkriz
[Today at 05:22:35 AM]


Fried Ampeg SVT-200T by Used.Benz.Parts
[December 07, 2018, 02:57:06 PM]


Simple SS Power Amp Build - +/- 40V Push/Pull by Jazz P Bass
[December 05, 2018, 01:19:15 AM]


British Maine solid state amps by FanofJapan
[December 04, 2018, 03:11:47 PM]

* Sponsors