Solid State Guitar Amp Forum | DIY Guitar Amplifiers

Please login or register.

Login with username, password and session length
Advanced search  

News:

SSGuitar has moved to PHP 7.1, enjoy the speed!

collapse
Pages: [1]   Go Down

Author Topic: Another Hohner Electric Piano - Cembalet CF  (Read 536 times)

aruption

  • SSGuitar Regular
  • ***
  • Chip Points: 0
  • Posts: 20
    • View Profile
Another Hohner Electric Piano - Cembalet CF
« on: October 23, 2018, 02:01:16 PM »

Just picked up another Hohner electric piano, this time the Cembalet CF:

http://hohner-cembalet.com/hohner_cembalet/Cembalet_CF.html

It powers up and does nothing but hum - no keyboard signal. Replaced the e-caps and resistors, same deal. The original volume pot had been removed and jumped together. Installing a replacement 250K pot did not make a difference, and does not affect the hum level when turned.

The vibrato bulb is burned out. I have a Cembalet N which does not have a working vibrato bulb, this does not stop the keyboard from working, it just means that I don't have a vibrato option, so I am assuming this one must work the same.

There is no voltage at the pickup. The other Hohner EPs typically have 150-200vdc at the pickup. This one also shows continuity between the pickup and the reeds. Even with the preamp unhooked from the pickup and reeds, their hookups on the board still show continuity, so it's not anything with the harp itself. None of the other Hohners behave this way, if they pickup and reeds have continuity, they are shorted and there is no sound. But this model has a strange coil thing in parallel with the reeds and pickup, which if I'm understanding the schematic correctly, would explain the continuity.

What's the next thing I should look at here? The transistors seem to have appropriate voltage readings. Thanks!

Logged

Cpt. FixIt

  • SSGuitar Regular
  • ***
  • Chip Points: 1
  • Posts: 21
    • View Profile
Re: Another Hohner Electric Piano - Cembalet CF
« Reply #1 on: November 03, 2018, 05:28:25 AM »

Sorry for the late reaction, I hope you found out how this particular Cembalet works in the mean time. If not:
In this model, there is no DC across the reeds, as you already found out. But how does it work?
The first transistor in the schematic, the AF101 to the very left, is used as a single transistor high frequency oscillator. The inductor across the reeds that seems to give you continuity is actually a secondary winding on that transistors collector inductor(making it a transformer actually). So you have a high frequency AC voltage across the reed assembly. If you hit a key, this HF gets modulated by the then "oscillating" capacity of the reed assembly.
Diode OA79 and capacitor 500pF demodulate it, just like it is done in a detector radio. The derived audio is then amplified by the following AC101 stage. The 1M trimpot in parallel to the LDR is used to adjust the intensity of the tremolo effect.
So if your instrument only puts out hum, you shpuld first check if your HF carrier is present/if your oscillator is working properly. I hope this helps.
Logged

aruption

  • SSGuitar Regular
  • ***
  • Chip Points: 0
  • Posts: 20
    • View Profile
Re: Another Hohner Electric Piano - Cembalet CF
« Reply #2 on: November 06, 2018, 02:26:25 PM »

Hi there!

I actually just learned that from another forum, and it makes sense now about the continuity that I'm seeing. Thanks! I brought it over to a guy who's much more knowledgeable that me. He hasn't had a chance to actually fix it yet, but he is pretty sure that the bridge rectifier is dead, and that the entire preamp is not getting the 12V it needs from the transformer. He's out of town for a couple weeks, but when he figures it out, I will report his findings back here!
Logged

aruption

  • SSGuitar Regular
  • ***
  • Chip Points: 0
  • Posts: 20
    • View Profile
Re: Another Hohner Electric Piano - Cembalet CF
« Reply #3 on: December 04, 2018, 08:36:38 AM »

When he finally got around to it, he found that the bridge rectifier was indeed dead, and replacing it got what he though are appropriate voltages to the entire board...except for the pickup, which still has 0 volts. He is pretty sure that the oscillator circuit is working properly, but is stumped about why there's no voltage on the pickup (and this guy's a savant with amp electronics). Any ideas about what I should look at next? I'm probably gonna go pick it up from him later this week.
Logged
Pages: [1]   Go Up
 

* User Controls
 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
* Recent Posts
Peavey Filter Caps by phatt
[December 13, 2018, 04:50:35 AM]


HH IC100L schematic anyone? by maxkriz
[December 12, 2018, 05:22:35 AM]


Fried Ampeg SVT-200T by Used.Benz.Parts
[December 07, 2018, 02:57:06 PM]


Simple SS Power Amp Build - +/- 40V Push/Pull by Jazz P Bass
[December 05, 2018, 01:19:15 AM]


British Maine solid state amps by FanofJapan
[December 04, 2018, 03:11:47 PM]

* Sponsors