collapse

Author Topic: SWR 550X Bass Amp Trouble  (Read 935 times)

aruption

  • Regular
  • **
  • Posts: 28
  • Chip Points: 0
    • View Profile
SWR 550X Bass Amp Trouble
« on: September 20, 2018, 09:46:35 PM »
Not sure if this is the best forum for this, but some folks on here have helped me out with an electric piano amp, so a bass amp shouldn't be too far fetched, right?

Anyway, a friend of mine asked if I could take a look at his SWR 550X bass amp. It had developed a pretty loud hum, and louder notes from the bass would cause a horribly buzzy clipping effect. This is one of those amps with an 12AX7 tube preamp section. We thought that replacing the tube might solve this, it did not.

What should I be looking at to clear up all this noise? I also had to replace the master volume pot because the shaft had broken off the original pot. The level of the hum increases as the master knob is turned up, as was the case before it was replaced. Any help is appreciated!

Enzo

  • Legendary
  • ******
  • Posts: 1850
  • Chip Points: 189
    • View Profile
Re: SWR 550X Bass Amp Trouble
« Reply #1 on: September 21, 2018, 02:00:52 AM »
Amps are amps, kinda doesn't matter if they are for bass, guitar, keyboards, etc.

First I would check the DC supplies in the amp.  The power amps run on something I know not what.  35v?  50v? 80v?  Whatever, will be plus and minus those.  Make sure the two polarities are about equal voltage and free of ripple.  Also the preamp will likely run on +/-15v supplies, so same checks there.

I would check through the signal path for any op amps putting out DC.

And of course I would check around the input jacks for broken ground solder connections.

tonyharker

  • Elite
  • ****
  • Posts: 139
  • Chip Points: 18
    • View Profile
Re: SWR 550X Bass Amp Trouble
« Reply #2 on: September 21, 2018, 06:21:57 AM »
The first thing I would do is to check the output for DC. To me it sounds like one of the output transistors has failed.

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Z-MATCHER 100W IMPEDANCE MATCHER by Loudthud
[September 16, 2019, 04:42:44 PM]


Hybrid valve and TPA311x by jfetter
[September 13, 2019, 03:29:50 PM]


Marshall 5010 Needs Help by Jazz P Bass
[September 13, 2019, 12:12:27 AM]


Do you need a low pass filter in your amp when you already have the eq? by slimjohnny
[September 11, 2019, 06:01:57 AM]


Gallien Kruger GT200 by mandu
[September 10, 2019, 06:31:10 AM]

* Sponsors