Solid State Guitar Amp Forum | DIY Guitar Amplifiers

Please login or register.

Login with username, password and session length
Advanced search  

News:

collapse
Pages: [1]   Go Down

Author Topic: MOSES mpx838 powered mixer output issue  (Read 213 times)

ilyaa

  • Legendary
  • ******
  • Chip Points: 5
  • Posts: 257
    • View Profile
MOSES mpx838 powered mixer output issue
« on: January 11, 2017, 08:13:57 PM »

hey everyone

working on this solid state powered mixer - main issue is i cant find a schematic anywhere so its a bit hard to troubleshoot it. its having a strange problem:

the output is nice and powerful, but once it gets to a certain volume, it starts to experience a periodic drop - every 1.5 seconds or so, the volume will dip between full power and 1/8 power - almost like a very slow tremolo. ive traced the problem to the power amp - it does not appear in the main preamp out, but does appear throughout the power amp. it only happens with a load plugged in - if i scope throughout the amp, all the way to the output transistors, when its unloaded, it works perfectly. but once a load is plugged in, the power amp seems unable to maintain full power.

now whats hard is that without a schematic i cant quite trace it properly - i was just wondering if anyone has a thought what might cause such a strange symptom?

its a long shot but anyone seen a schematic for this thing around??
Logged

Enzo

  • Legendary
  • ******
  • Chip Points: 171
  • Posts: 1564
    • View Profile
Re: MOSES mpx838 powered mixer output issue
« Reply #1 on: January 11, 2017, 08:57:24 PM »

What load are you using?   What rating is on the amp?  My Mackie subwoofers will motorboat on a 4 ohm load, but not the specified 8 or 12 ohm load.
Logged

ilyaa

  • Legendary
  • ******
  • Chip Points: 5
  • Posts: 257
    • View Profile
Re: MOSES mpx838 powered mixer output issue
« Reply #2 on: January 12, 2017, 08:19:33 PM »

whoa interesting result -

it says 4 ohms on the back - but it motorboats into a 4 ohm load. into an 8 ohm load its all good!

it says 250W into 4 ohms on the back, but there are two jacks per side. i was plugging one 4 ohm load into just one of the jacks on just one of the sides.
Logged
Pages: [1]   Go Up
 

* User Info
 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
* Recent Posts
Jordan Professional 440 Solid State IC Amp Head by teemuk
[April 27, 2017, 07:58:53 AM]


Strange amp in a suitcase by J M Fahey
[April 27, 2017, 05:42:47 AM]


DIY Layout Creator by DrGonz78
[April 26, 2017, 08:40:13 AM]


Marshall Lead 100 MOSFET 3210 Head by J M Fahey
[April 26, 2017, 12:59:30 AM]


More differential amplifier questions by phatt
[April 24, 2017, 09:05:25 AM]

* Sponsors