Welcome, Guest. Please login or register.

September 29, 2020, 07:13:31 PM

Login with username, password and session length

Recent Posts

 

Author Topic: Polytone Mini Brute V preamp to power amp connection  (Read 2749 times)

jerseyjoe

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 0
    • View Profile
Polytone Mini Brute V preamp to power amp connection
« on: October 15, 2015, 11:31:10 PM »
Hello. New to the forum. After searching the internet and every forum I could find for an answer to my problem, figured that maybe somebody here could be of help.

I'm in the process of converting a 1998 Polytone Mini Brute V Combo amp into a head that I can run with different speakers. I pulled the control board and power amp and disconnected everything. Now that my new cabinet is basically finished, I wanted to do a test run and realized that I've got one wire that that must have broke free from it's solder during the manhandling. It's the black wire (in the circle) that connects to the control board somewhere? and then to the power amp with a single rca jack... I didn't see it disconnect and after scanning the board for something that looks undone, still nothing. The polytone schematics I've seen online don't really make sense to me. I believe this black wire connects the preamp to the power amp, but how or where?  Can anybody here help with this? Thanks.

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #1 on: October 15, 2015, 11:42:21 PM »
Hard to guess.
Your picture only shows part of a black wire, the top end disappears behind a PCB, the bottom end goes out of the screen and also disappears in an aunknown way, how could anybody guess?

jerseyjoe

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 0
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #2 on: October 15, 2015, 11:47:09 PM »
right. the problem is i took the pictures for reference before the wire came undone. i have no idea what it's connected to. i'm looking for somebody familiar with polytone wiring that could tell me where on the board that wire is connected to.

Enzo

  • Legendary
  • ******
  • Posts: 1977
  • Chip Points: 214
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #3 on: October 16, 2015, 01:03:18 AM »
We can't see where either end connects.  Presumably one end has broken free, but the other end is still connected to...SOMETHING?

There are only so many subsections of the amp, so power amp to preamp is a good guess, and if I had to guess further, I'd suspect it is a ground connecting the two board grounds together.  But knowing where at least one end came from, helps us determine where the other end goes.

jerseyjoe

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 0
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #4 on: October 16, 2015, 01:06:07 AM »
as i said in the original post, one end goes to a single rca jack that connects to the power amp at the base of the cabinet. the other mystery end connects to the board, which at the time of the photo was connected. now it's not.

jerseyjoe

  • Chipper
  • *
  • Posts: 4
  • Chip Points: 0
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #5 on: October 16, 2015, 01:57:26 AM »
maybe pictures will help. the black cable is not bundled with anything. it did go directly from the board to an rca input on the power amp.

DrGonz78

  • Legendary
  • ******
  • Posts: 562
  • Chip Points: 69
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #6 on: October 16, 2015, 02:34:51 AM »
Sorry if I missed it but please post the schematic you are referencing. Also, if the wire broke free from it's connection there might be a soldered connection point that has some of the broken wire sticking out. So it is an RCA cable and the Poiytone amps I have worked on had that type of cable running the preamp signal output to the input on the power amp.

From looking at this schematic I see the power amp output RCA connection is as follows. E13 connects tip and E14 connects the ground of that wire. That as the best I can say for now. I can't see great close up detail from your picture, but I kinda see some broken wired connection on E13 and E14.
“A person who never made a mistake never tried anything new.” -Albert Einstein

g1

  • Legendary
  • ******
  • Posts: 660
  • Chip Points: 79
    • View Profile
Re: Polytone Mini Brute V preamp to power amp connection
« Reply #7 on: October 16, 2015, 12:03:33 PM »
  If Dr.Gonz' schematic is the right version, then E13 comes off one side of R21.