collapse

Author Topic: Fender Mustang II v.2  (Read 54 times)

scottishmac2012

  • Chipper
  • *
  • Posts: 1
  • Chip Points: 0
    • View Profile
Fender Mustang II v.2
« on: December 08, 2019, 04:35:09 AM »
The Amp is a Fender Mustang II v.2  40 watt combo amp with a 12" stock speaker.   After I power up the amp randomly shuts off or looses power ...for no apparent reason?   What could be the problem?  As well as the possible solution's?

phatt

  • Legendary
  • ******
  • Posts: 2037
  • Chip Points: 241
    • View Profile
Re: Fender Mustang II v.2
« Reply #1 on: December 08, 2019, 06:08:35 AM »
Rule out the simple things first;
If the Amp has an Effects Loop then bridge those in/out sockets with a guitar cord.
This bypasses the internal switch inside the socket.
This is a very common fail point in many amplifiers as they all seem to use flimsy contacts for the internal switch now days.
Phil.

Jazz P Bass

  • Elite
  • ****
  • Posts: 164
  • Chip Points: 13
    • View Profile
Re: Fender Mustang II v.2
« Reply #2 on: December 08, 2019, 03:28:54 PM »
The issue needs be to better defined.
Shuts off as in the front indicator goes out?

Enzo

  • Legendary
  • ******
  • Posts: 1867
  • Chip Points: 194
    • View Profile
Re: Fender Mustang II v.2
« Reply #3 on: December 08, 2019, 04:46:37 PM »
Agree^^^

Do you mean the power goes off, as in the power light goes dark?  Or do you simply mean the sound goes away?

 

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Fender Mustang II v.2 by Enzo
[December 08, 2019, 04:46:37 PM]


Eight Audio Kit TDA7294 and TDA2050 from India by g1
[December 08, 2019, 03:11:47 PM]


signal tracing by Crich
[December 07, 2019, 07:43:20 PM]


The Dangers of Speaker Impedance Mismatching by Enzo
[December 05, 2019, 11:44:14 AM]


Gallien Kruger GT200 by gbono
[December 04, 2019, 02:54:12 PM]

* Sponsors