Welcome, Guest. Please login or register.

October 26, 2020, 08:42:48 AM

Login with username, password and session length

Recent Posts

 

Author Topic: debugging a small amp  (Read 31181 times)

joecool85

  • SSGuitar Admin
  • Legendary
  • ******
  • Posts: 3327
  • Chip Points: 991
  • SSG Creator
    • View Profile
    • thatraymond.com
Re: debugging a small amp
« Reply #15 on: May 31, 2011, 11:29:10 AM »
I agree with Juan.  No matter how good you are, mistakes happen.  Best to go through it and check for any issues.
Life is what you make it.
Still rockin' the Dean Markley K-20X
thatraymond.com

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #16 on: June 25, 2011, 10:25:23 AM »
Okay, I don't really know how this stompbox should be but I decided to check if the schematic the the PCB are the same (after that I'll follow this guide:http://www.geofex.com/fxdebug/newfx.htm)

I have some question:
1. What is the purpose of the red section?
2. Where the 9V (blue) should connect to?
3. All the VB points connect together but what the hell is VB?


Alexius II

  • Master
  • ***
  • Posts: 72
  • Chip Points: 6
    • View Profile
Re: debugging a small amp
« Reply #17 on: June 25, 2011, 11:35:31 AM »
I think I can provide an answer:

1. the red section is "power supply" (led power, filtering, provides a reference voltage)
2. 9V (blue) should probably connect to the + side of that 100uF capacitor at the power supply
3. VB is just a name for a reference voltage; in this case I believe VB is at 4.5V (or half the supply voltage)

Hope this helps. Please someone correct me, if I'm wrong  ::)
« Last Edit: June 25, 2011, 11:37:16 AM by Alexius II »

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #18 on: June 25, 2011, 11:38:35 AM »
Okay, The 9v really connects there and the part after the 100uf cap is to get 4.5volt but why there is a grounded diode and a resistor between the 9V source and the 9V+?

I checked the parts values and discovered some things.
Instead of 13.3k resistor I got 12k, instead of 27n cap I got 33n, instead of 20n cap I got 22n. Is getting these exact values is very important or is it okay to leave it just as it is?

Also I got mixed with the group of 4 resistors (D1 to D4). In the schematic the upper couple are turning left and the lower couple are turning right, in the pcb the upper couple turning right and the lower turning left. I did it as in the pcb. Is this important that I'll change them to be as in the schematic or it will work just fine if they'll stay as the pcb says.

I need to check the connection on the pcb but first I need to change a battery in my multimeter-I'll check the solder joints on the same time
« Last Edit: June 25, 2011, 11:57:04 AM by kin0 »

phatt

  • Legendary
  • ******
  • Posts: 2141
  • Chip Points: 261
    • View Profile
Re: debugging a small amp
« Reply #19 on: June 26, 2011, 06:43:23 AM »
Hi kino,,
           D5 is simply to save the circuit from reversed polarity,, battery connected backwards etc.

22nF is close enough to 20nF. as with most of these values it's not super critical.
If you must have 13.3k then 10k + 3k3,, again hardly worth the fuss as 12 k is likely close enough.

As mentioned VB is the offset voltage, or VB (Voltage bias)
to get these devices to work from a single supply you need to lift the input halfway,, in this case 4.5 VDC is the bias point.

Then of course they need to be decoupled via a capacitor for them to work.
R13 is not needed on Battery but if you run from a plug pak with other devices connected to same it can help filtering issues.
Phil.

phatt

  • Legendary
  • ******
  • Posts: 2141
  • Chip Points: 261
    • View Profile
Re: debugging a small amp
« Reply #20 on: June 26, 2011, 06:44:49 AM »

Oh forgot the other diodes.
                                      Two go forward two go backwards otherwise it won't work as intended.
Phil.

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #21 on: June 26, 2011, 12:26:20 PM »
my question was is it important which pair goes forward and which pair backward or not?
And thanks for the other answers

Alexius II

  • Master
  • ***
  • Posts: 72
  • Chip Points: 6
    • View Profile
Re: debugging a small amp
« Reply #22 on: June 26, 2011, 12:57:18 PM »
my question was is it important which pair goes forward and which pair backward or not?
And thanks for the other answers
If all diodes are of the same type, than no, it is not important.  :tu:

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #23 on: June 26, 2011, 01:05:26 PM »
oh crap now I have to look for another problem. Cool smili by the way. ;)

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #24 on: July 06, 2011, 11:53:12 AM »
I checked if everything on the pcb is connected well. There were some places that have to be connected (not a problem) but there are some places that are connected to the ground while the shouldn't be. I can't find the exact place that they are connected (to know there to disconnect). Here is there I have the problems.


J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: debugging a small amp
« Reply #25 on: July 06, 2011, 12:56:36 PM »
Label them with a letter, for clarity.
What do the red lines mean?
Both ends are connected?
Either end is ground?

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #26 on: July 06, 2011, 04:29:01 PM »
the red lines mean that i put the multi meter in the both ends of the line and it made a sound (means that these two points are connected to each other somhow). In several of these point I can see clearly where they are connected but in others I just can't see anything wrong. How can I find what to fix in those that I can detect any visual connections.

phatt

  • Legendary
  • ******
  • Posts: 2141
  • Chip Points: 261
    • View Profile
Re: debugging a small amp
« Reply #27 on: July 06, 2011, 06:24:24 PM »
Kin0,
       You will have better results if you learn to Work in Nodes,, not just what the layout looks like.
Example;
            The very first input has the Input, R1 and C1.
All 3 connect to one point/Node.
ONLY Those 3 components connect to that place on the circuit board.
If you number each NODE on the schematic it will make the whole layout more clear.
Have fun,, Phil.

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: debugging a small amp
« Reply #28 on: July 07, 2011, 01:40:52 AM »
Please re-post labelling the "red lines" to be able to give you a useful answer.
As in: "a", "b", "c", etc.

kin0

  • Master
  • ***
  • Posts: 95
  • Chip Points: 2
    • View Profile
Re: debugging a small amp
« Reply #29 on: July 07, 2011, 11:30:10 AM »
I don't understand what do you mean  :o