Welcome, Guest. Please login or register.

November 26, 2020, 06:53:43 PM

Login with username, password and session length

Recent Posts

 

Author Topic: I blew another amp.  (Read 5601 times)

RDV

  • RIP - 2/5/10
  • Elite
  • ****
  • Posts: 291
  • Chip Points: 419
    • View Profile
    • Fatboy Effects
I blew another amp.
« on: May 04, 2006, 07:40:52 AM »
I'm about done with non-insulated versions of chipamps.

I forgot that I had an insulator around my speaker jack for the original perfboard chipamp guitar-amp I built and fried it last night by touching the metal plug casing to to the heatsink and grounding it out. SNAP!! What a sick feeling. I'm gonna insulate them from now on or I'm not gonna even plug them in.

I'm gonna cut the chipamp part of the perf off and use the rectifier section on another chipamp. I'll post anything positive.

RDV

joecool85

  • SSGuitar Admin
  • Legendary
  • ******
  • Posts: 3330
  • Chip Points: 991
  • SSG Creator
    • View Profile
    • thatraymond.com
Re: I blew another amp.
« Reply #1 on: May 04, 2006, 08:37:13 AM »
I just use insulated versions.  With the exception of my lm1875, but that is never open and I was careful to use the insulator ring and a ceramic so none of it is grounding to my sink.

Good luck on fixing this one.  How much got fried this time?
Life is what you make it.
Still rockin' the Dean Markley K-20X
thatraymond.com

RDV

  • RIP - 2/5/10
  • Elite
  • ****
  • Posts: 291
  • Chip Points: 419
    • View Profile
    • Fatboy Effects
Re: I blew another amp.
« Reply #2 on: May 04, 2006, 09:29:15 AM »
How much got fried this time?
The chip. I smelled that smell of burned plastic again. It wasn't as violent as the end of the 4780 but it's just as dead. I'm going to cut the perf away just leaving the PS part and try my rescued LM4780 board again there. I'm using an insulating pad on it and strapping down the chip instead of bolting direct so hopefully the heatsink will not be charged. I'm gonna do the same thing to the subamp. I've got to tighten up and stop screwing up everything. I'm a legendary half-asser.

RDV

joecool85

  • SSGuitar Admin
  • Legendary
  • ******
  • Posts: 3330
  • Chip Points: 991
  • SSG Creator
    • View Profile
    • thatraymond.com
Re: I blew another amp.
« Reply #3 on: May 04, 2006, 09:46:02 AM »
LOL!  Legendary half-asser.
Life is what you make it.
Still rockin' the Dean Markley K-20X
thatraymond.com

RDV

  • RIP - 2/5/10
  • Elite
  • ****
  • Posts: 291
  • Chip Points: 419
    • View Profile
    • Fatboy Effects
Re: I blew another amp.
« Reply #4 on: May 05, 2006, 03:09:38 PM »
I don't have any time. I fixed the non-working LM4780 board and put it in the guitar amp. I'll post more 2morrow.

RDV

RDV

  • RIP - 2/5/10
  • Elite
  • ****
  • Posts: 291
  • Chip Points: 419
    • View Profile
    • Fatboy Effects
Re: I blew another amp.
« Reply #5 on: May 06, 2006, 03:53:13 AM »
The guitar amp really sounds good using the paralleled LM4780. I'm probably just in the "Honeymoon stage' but it deeper and less fizzy to my ears than the LM3886 ever did. We'll see when I can do some higher volume testing.

RDV

joecool85

  • SSGuitar Admin
  • Legendary
  • ******
  • Posts: 3330
  • Chip Points: 991
  • SSG Creator
    • View Profile
    • thatraymond.com
Re: I blew another amp.
« Reply #6 on: May 06, 2006, 07:39:39 PM »
I would assume this is too shearly having more wattage which will allow for that more than anything else.
Life is what you make it.
Still rockin' the Dean Markley K-20X
thatraymond.com

RDV

  • RIP - 2/5/10
  • Elite
  • ****
  • Posts: 291
  • Chip Points: 419
    • View Profile
    • Fatboy Effects
Re: I blew another amp.
« Reply #7 on: May 07, 2006, 01:05:36 AM »
That certainly makes sense because the LM4780 is just 2 LM3886 in a single die. It still sounds good though. I won another toroid on ebay. This one was a bargain. It's 20v + 20v 200VA.

RDV