collapse

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - GlenF

Pages: [1]
1
The Newcomer's Forum / Re: Heathkit TA16
« on: May 12, 2019, 10:33:44 PM »
I'll look into that.  Thanks for the info!

2
The Newcomer's Forum / Re: Heathkit TA16
« on: May 12, 2019, 09:51:39 AM »
I think I am the right path.  In the pic, there are 4 little black diodes (I think that's what they are).  When I test the 2 on the left, I get readings from the top lead, but not the bottom.  On the right 2, I get readings from both ends.  Is this normal?

3
The Newcomer's Forum / Re: Heathkit TA16
« on: May 12, 2019, 09:06:53 AM »
And the meter I have.

4
The Newcomer's Forum / Re: Heathkit TA16
« on: May 11, 2019, 10:12:34 AM »
And the other side.

5
The Newcomer's Forum / Re: Heathkit TA16
« on: May 11, 2019, 10:10:29 AM »
Thanks Phil.

6
The Newcomer's Forum / Re: Heathkit TA16
« on: May 11, 2019, 08:20:09 AM »
I'm certainly no pro, like you guys.  If you could give me some pointers, that would be great!  My dad did the majority of the work back in the early 70's, and I changed a few wires 5 years ago.  If you could point out which joints look iffy, I could redo them. 

7
The Newcomer's Forum / Re: Heathkit TA16
« on: May 10, 2019, 07:04:32 PM »
Thanks for the help Den!

8
The Newcomer's Forum / Re: Heathkit TA16
« on: May 10, 2019, 05:57:24 PM »
 I have tried three times to upload a pic.  It keeps telling me the file size is too large.  Not sure what to do now.

9
The Newcomer's Forum / Re: Heathkit TA16
« on: May 09, 2019, 10:23:02 PM »
Before I start to take readings, there is alot of brownish stains on the outside of the solder.  Is this exess flux, and could this be part of the problem?

10
The Newcomer's Forum / Re: Heathkit TA16
« on: May 08, 2019, 08:33:59 PM »
I have the board out of the amp right now.  To do the tests, do I need to have it plugged into the wall so that there is power to the board or can I do the tests unplugged?

11
The Newcomer's Forum / Re: Heathkit TA16
« on: May 05, 2019, 04:10:06 PM »
I'm not sure where the +38Vdc rail is, and how do I remove the speaker load?  I'm not an electrician, but I want to learn more about these things.

12
The Newcomer's Forum / Re: Heathkit TA16
« on: May 05, 2019, 10:33:45 AM »
Thanks for getting back to me!  I have a power light, bur no sound.
Here is the site I got the schematic from.

https://elektrotanya.com/heathkit_ta-16_guitar_amplifier_sch.pdf/download.html

Hope this helps.

13
The Newcomer's Forum / Heathkit TA16
« on: May 04, 2019, 09:47:00 PM »
Hello everyone.  I have an old Heathkit TA16 giutar amp my dad built for me when I was a kid.  I wanted to bring it back out and start playing again, but when I plugged it in, nothing.  I am no electrical wizard, but I can learn with help.  I have worked on it before and had it working, but there is no sound now.  Where do I start?  Any help would be great!  Thanks in advance.

Pages: [1]

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Z-MATCHER 100W IMPEDANCE MATCHER by Loudthud
[September 16, 2019, 04:42:44 PM]


Hybrid valve and TPA311x by jfetter
[September 13, 2019, 03:29:50 PM]


Marshall 5010 Needs Help by Jazz P Bass
[September 13, 2019, 12:12:27 AM]


Do you need a low pass filter in your amp when you already have the eq? by slimjohnny
[September 11, 2019, 06:01:57 AM]


Gallien Kruger GT200 by mandu
[September 10, 2019, 06:31:10 AM]

* Sponsors