collapse

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - alessandro_gfdp

Pages: [1]
1
Amplifier Discussion / Re: Fuse or resistor?
« on: June 18, 2019, 05:37:48 AM »
Looks like a fuse,blown

Inviato dal mio Redmi Note 5 utilizzando Tapatalk


2
Tubes and Hybrids / Re: ENGL Fireball E625 Head white noise issue
« on: June 01, 2019, 03:10:45 AM »
no,the ultra channel uses 4 stages,the clean 3.
I had the same exact problem in the same amp,from a friend.
It developes over years,its not related to new or old tubes,in fact the old tubes were pretty good.Not related to anode or cathode resistors,changed all of them
I was running out of time and ended applying a coring circuit for noise reduction,but to me that is not the best solution.
Its all in the first 4 triodes,one thing i didn't do and maybe has value is to remove any trace of glue on the flat cables and the caps,and maybe substitute the filter caps,and wash the board and sockets with isoprop alcohol.

Pages: [1]

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Yamaha G100 410 - Series 1 - Low Volume / Surges when turning off. by ryanckelso
[July 15, 2019, 03:05:35 PM]


LND150 Jose style preamp by Zozobra
[July 15, 2019, 05:42:06 AM]


Peavey Session 400 1976 troubleshooting by Jazz P Bass
[July 13, 2019, 10:14:27 AM]


Lab Series L3 by jman
[July 12, 2019, 11:02:11 PM]


Can someone school me on solid state amps with great clean tones? by PMc
[July 09, 2019, 04:59:33 PM]

* Sponsors