Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mattharrier

Pages: [1]
1
The Newcomer's Forum / Re: Hello and a question about a Line 6 Spider 3
« on: February 12, 2020, 12:06:17 PM »
I finally found time to take a look, and it's much simpler than I thought (I didn't realise this until I'd already made it more complicated!).

The bolts in the front didn't need to come out at all, and there's a plate at the top of the front panel of the cabinet, which looked like it was attached to the amp, but wasn't.

Long story short, I got it open, sadly couldn't see any loose connections, so put it back together again. The screen still doesn't work, but the good news is that the amp still does.

I'll see if any local shops will take a look without charging the earth, but otherwise I'll keep an eye out for a Shortboard (which has its own screen), and carry on as I have been in the meantime.

Thanks for the advice everyone.

2
The Newcomer's Forum / Re: Hello and a question about a Line 6 Spider 3
« on: February 06, 2020, 03:51:04 AM »
That does indeed help, thanks very much! It was quite late last night so as soon as I realised it wasn't quite as simple as I thought, I put it back together and left it alone for another time!

I think it may be beyond my abilities, but if I can get it out I can at least take the top panel off and have a peek inside. I'll have another go at the weekend and let you know how I get on.

3
The Newcomer's Forum / Re: Hello and a question about a Line 6 Spider 3
« on: February 05, 2020, 06:16:53 PM »
Well, I had a quick look tonight, and while I can see four Allen bolts that look like they should allow removal of the whole amp unit from the cabinet, it isn't as simple as that. There are two plastic corner protectors that look like they need to be removed first, but they appear to be held in place by the instrument panel that they appear to in the way of!

Any general tips to disassembling combo units? I've attached a photo of the front of the panel if that helps.

4
The Newcomer's Forum / Re: Hello and a question about a Line 6 Spider 3
« on: February 04, 2020, 03:18:44 PM »
Thanks Joe cool, I'll have a look when I get time. I'm hoping it's as easy as a loose connection, but we'll see!

5
The Newcomer's Forum / Hello and a question about a Line 6 Spider 3
« on: February 04, 2020, 06:53:46 AM »
Hi folks,

I'm fairly new to the guitar world, and I'm certainly no electronics genius. I won't be building an amp from scratch or anything like that so hopefully my questions will be few and simple!

I have acquired a Line 6 Spider 3 amp, and while everything seems to function as it should (plug guitar in, hit strings, noises come out and change when knobs are turned), the LCD screen doesn't work. No display, no backlight.

If I take the control panel off and have a look, a) is there any chance I might kill myself and b) am I likely to be able to get a replacement screen and swap them over?

I know that a new screen wouldn't fix the issue if it's something else (and short of an obviously broken/damaged connection I don't have the knowledge to diagnose anything), but does anyone know these amps well enough to offer any insight?

Cheers,

Matt

Pages: [1]