Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Bill Moore

Pages: [1] 2 3
1
Amplifier Discussion / Re: Peavy 130 Special needs some TLC
« on: July 21, 2020, 12:09:49 PM »
I had a Special 150 a while back that I brought back to life. The output side fuse was blown. I changed all the output transistors, and after advise from knowledgeable folks here, and elsewhere, I pulled and tested all the (driver?) transistors. After i replaced them, all is well! (dim light, intact fuse, and of course, sound!)

2
Amplifier Discussion / Re: My K-20X
« on: March 02, 2020, 05:46:19 PM »
Now I'll have to try that!
I gave my first little amp away, but last year a fellow wanted to trade a "practice amp" for a pedal I had. I was surprised when he showed up with another Dean Markley. One of the pots had the shaft pulled loose, and after searching for a replacement. I ended up repairing the original. Speaker is a little rough, but at low volume it isn't noticeable.
Now reverb?

3
Amplifier Discussion / Re: Match Output Transistors?
« on: October 09, 2019, 05:41:22 PM »
Finally got back to it, and tested all the preamp TO-92 transistors. At least one of each pair were faulty! I found the equivalents, installed them, and it lives! I removed the limiter and connected to A/C, and played my guitar through it, sounds OK.
I now need to modify the Special 112 rear cover/heat sink to fit, still debating whether to add more cooling fins, (the Special 130/150 are a lot larger). I can leave the footswitch jack, but need to lift the pre out, and power amp in, because of the spacing. I may just jumper the power amp jack connections, and forget about them. Since there are holes for speaker jacks, I'll use std. switchcraft and take advantage of them. They are marked 4 and 8 ohm, so I assume the 112 had a transformer output, parallel will have to do.

4
Amplifier Discussion / Re: Match Output Transistors?
« on: September 01, 2019, 04:30:41 PM »
Well, I found parts, and replaced the outputs, as well as the other transistors in the power amp section. I installed the limiter, and evidently I lost my short, so I decided to connect a speaker. Now I get a hum, and it starts to "squawk", before I shut off power!
I suppose I need to look at the preamp section now!

5
Amplifier Discussion / Re: Match Output Transistors?
« on: August 16, 2019, 05:42:37 PM »
Thanks, I see now, use the "other" in house number for a guide. I ordered the outputs for about $14 shipped, need some time to look for the others.

6
Amplifier Discussion / Re: Match Output Transistors?
« on: August 15, 2019, 07:28:20 PM »
It could be that Peavey is the only source for the MJ 15052 MJ 15053, as a search doesn't yield much. I suppose there is another interchange I may have to pursue.

7
Amplifier Discussion / Re: Match Output Transistors?
« on: August 15, 2019, 11:47:08 AM »
Thank you also, Enzo!
Peavey was kind enough to e-mail the Schematic/Layout, and I found the cross reference on the web.
I measured for opens across the resistors, and lifted a leg of the diodes to check them. Maybe I'll check the resistors once more while the transistors are out of the circuit. My friend had given me a hand full of components with the chassis, and I changed the P/S caps, but the originals tested good. I still need to test the rest of the transistors, it really would be nice if they had sockets! I have been clipping an alligator clip to the leg I am lifting, trying not to overheat the things!
The rear chassis/heatsink was missing, I found one for an older Special 112 that I've modified. It doesn't have as many fins, but I think it will work well enough, (I doubt it will ever be asked to run at full power.

8
Amplifier Discussion / Re: Match Output Transistors?
« on: August 14, 2019, 06:13:36 PM »
Thank you!
I guess I was trying to be cheap, but worried that mixing replacement part numbers wouldn't work. I do have the driver transistors, (one of those was also shorted), maybe I'll learn something from the experience.

9
Amplifier Discussion / Match Output Transistors?
« on: August 14, 2019, 11:20:18 AM »
I have a Peavey Special 150 that a friend gave me years ago, (dead). He already had replaced some parts, and had given up, (blowing fuses). I repaired some open traces on the board, but it still had a draw on the power amp side. The original outputs were replaced, but with replacement numbers, I tested them all, and one is shorted, (they were incorrectly installed)! I'm not sure if I can find the replacement number of the dead one, and was considering replacing all, is that really necessary?
If I have a bad output tube in push-pull, I always replace them all, but I'm only wanting to get this project working, not rebuilt!

10
Amplifier Discussion / Re: How to build an amp to run on solar power
« on: June 20, 2018, 06:28:51 PM »
Thanks for the memories, Juan! As a kid on the ranch, we would spend a week or more at a time at a couple of "camps". Really decent places, (us boys had a bed on the screened porch). Had a propane refrigerator, and stove, usually hung a quarter of beef in the shade in the porch covered with a tarp. Not old Lister power, but WWII Navy 4 cyl generators, usually run for an hour or two, and then lights out, they too were pretty efficient! The neighbor west of there had a Wincharger, and batteries, had lights as long as you wanted at night, even in the bunkhouse, (and a radio!) The kitchen even had a toaster! I don't remember staying up too late at night, as morning, (and breakfast) came before full sunrise! We took turns wrangling the horses, and since it was dark, we would look for old man Tom's white mule, to find the stock.

11
Amplifier Discussion / Re: My K-20X
« on: June 30, 2017, 04:32:43 PM »
I have posted before on my little K-20, and had intended to experiment some with it.
Our (only) grandson was down a month ago, and likes an amp with OD, but most I have at the house need to really be loud for that. I showed him the Dean Markley, and he played through it a little, and said it was OK. For several days he would go into the music room, and play, always choosing the little K-20. When we were getting ready to take him back to the airport, I found a bag that would fit the little amp in, and told him to take it home. (I had to pay to check his other bag, but I was happy to do so). It now resides in Alaska, and his mom said he is really proud of it!

12
Amplifier Discussion / Re: Great little amp!
« on: December 29, 2016, 05:35:47 PM »
Well it's been 3 years, but I got my little Dean Markley amp back!
I think I will try one of the Eminence 8" speakers, and see if it does fatten up the bottom end a little.

13
Amplifier Discussion / Re: Bi-amping/ Tri-amping
« on: May 11, 2016, 07:05:19 PM »
Years ago, I built the the PA cabinets for our band, and since EV supplied their drawings, I built the TL series bass bins. The bass bins were 13 cu. ft., the mids were 1/2 of the TL series 4-12 cab, and then HR90 horns. We tri-amped mono, and it worked great for our R&R band.
A few years later, my wife's sister came back to town, so we put together a country band, did away with the mids, and ran stereo bi-amped. It too worked great, but moving the large bins around in some of the smaller venues was tough. (And also the fact, that with 3 girls in the group, it was always me, and the guitar player moving them!) I decided we needed the smaller TL 7 cu. ft. bins, and built a couple. While installing insulation, I had the old PA playing music, (maybe it was a little loud). When I stuck my head into the speaker cutout, you could really hear the frequency the box was tuned to! Never thought before how the tuning thing really works!

14
Amplifier Discussion / Re: Peavey Transtube Studio Pro 112 (Silver Stripe)
« on: February 11, 2016, 11:46:06 AM »
Seems a common problem on a lot of the inexpensive Peavey, and Fender amps.  I keep some jacks in my spares box, and if the circuit board has to come out, it gets new jacks! I did clean a few, with a burnishing tool,  (they will came apart easily), but I don't think it's worth the effort.

15
Amplifier Discussion / Peavey Reverb Cable.
« on: September 10, 2015, 01:25:36 PM »
Thought I would share this. Some Peavey amplifiers have a 5 pin Molex connector that attaches to the circuit board to connect the reverb tank. I had no luck finding one anywhere, but found that 2 2 pin connectors will work.
Molex Recepticle  03-09-1027
Molex Terminal     02-09-1119





Pages: [1] 2 3