collapse

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - aruption

Pages: [1]
1
Amplifier Discussion / Ampeg SVT450
« on: February 14, 2019, 07:21:55 AM »
My friend just picked up an Ampeg SVT450 that's definitely got some issues. Plugging either speaker output into any speaker, any notes played on any instrument are super distorted, and do not sustain. Using the line out post, and note played is distorted and sustains infinitely. Only the line out pre sounds normal, but that of course is because it's bypassing pretty much everything in the amp. What should we first take a look at under the hood?

2
Amplifier Discussion / Another Hohner Electric Piano - Cembalet CF
« on: October 23, 2018, 02:01:16 PM »
Just picked up another Hohner electric piano, this time the Cembalet CF:

http://hohner-cembalet.com/hohner_cembalet/Cembalet_CF.html

It powers up and does nothing but hum - no keyboard signal. Replaced the e-caps and resistors, same deal. The original volume pot had been removed and jumped together. Installing a replacement 250K pot did not make a difference, and does not affect the hum level when turned.

The vibrato bulb is burned out. I have a Cembalet N which does not have a working vibrato bulb, this does not stop the keyboard from working, it just means that I don't have a vibrato option, so I am assuming this one must work the same.

There is no voltage at the pickup. The other Hohner EPs typically have 150-200vdc at the pickup. This one also shows continuity between the pickup and the reeds. Even with the preamp unhooked from the pickup and reeds, their hookups on the board still show continuity, so it's not anything with the harp itself. None of the other Hohners behave this way, if they pickup and reeds have continuity, they are shorted and there is no sound. But this model has a strange coil thing in parallel with the reeds and pickup, which if I'm understanding the schematic correctly, would explain the continuity.

What's the next thing I should look at here? The transistors seem to have appropriate voltage readings. Thanks!


3
Amplifier Discussion / SWR 550X Bass Amp Trouble
« on: September 20, 2018, 09:46:35 PM »
Not sure if this is the best forum for this, but some folks on here have helped me out with an electric piano amp, so a bass amp shouldn't be too far fetched, right?

Anyway, a friend of mine asked if I could take a look at his SWR 550X bass amp. It had developed a pretty loud hum, and louder notes from the bass would cause a horribly buzzy clipping effect. This is one of those amps with an 12AX7 tube preamp section. We thought that replacing the tube might solve this, it did not.

What should I be looking at to clear up all this noise? I also had to replace the master volume pot because the shaft had broken off the original pot. The level of the hum increases as the master knob is turned up, as was the case before it was replaced. Any help is appreciated!

4
Amplifier Discussion / Hohner Pianet Amplifier Low Output
« on: April 15, 2018, 11:17:56 AM »
Not a guitar amp, but I'm hoping someone here might be able to help me out!

I've had a Hohner Pianet L for about a year now.  For those of you who aren't familiar with it, it's the first solid state electric piano that Hohner produced.  This particular model has built in speakers.  More info and schematics are here: http://hohner-pianet.com/hohner_pianet/pianet_L_LB.html

It's come a long way from when I bought it, when it made no sound at all.  All of the caps have been replaced as well as most of the resistors and the volume pot.  Mechanically, everything is in perfect shape.  The main problem I'm still fighting is a rather low volume output.  Compared to the other Hohner electric pianos I own (Pianet N and Cembalet N), this one just does not have the same volume.  It is very quiet until the volume pot reaches about 80%, then there is a sudden increase in volume AND distortion.  This volume level is closer to where I believe it should be, but the distortion doesn't seem right.  Overall, there is a buzzing in the background which isn't much worse than say the buzz from a Strat pickup.  The level of this buzz (and any other background noise) is affected by the volume pot in the same manner as the actual piano sound.  The output sounds the same through both the internal speakers and the output jack.  Also, I've tried three different volume pots now, all with the same results.

I've come to this forum because I'm hoping that someone with experience in SS amps in general might be able to help me out.  I've brought this up on other vintage keyboard forums, but haven't really gotten anywhere.

Pages: [1]

* User Controls

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Peavey Audition Plus by psafloyd
[October 17, 2019, 03:24:56 PM]


Carlsbro Hornet (1970s) by psafloyd
[October 16, 2019, 11:37:28 AM]


Thoughts on the difference in sound between tubes and solid state by jfetter
[October 15, 2019, 07:59:26 AM]


I want to ask a question by Jmatt
[October 11, 2019, 10:47:17 PM]


Does A500 mean 500 ohms or 500k ohm by slimjohnny
[October 11, 2019, 07:11:19 PM]

* Sponsors