Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - lovatomi

Pages: [1]
1
Amplifier Discussion / 1967 Mosrite BG-500 Output Transistor Bias Question
« on: February 21, 2021, 09:45:19 AM »
Hi all. I have an old Mosrite SS amp that I am working on getting back into good working condition. It had a few blow transistors in the output stage (as well as a couple light bulbs?!) and I have replaced the suspect parts. When i fired it up and scoped it i noticed I was getting a fair amount crossover distortion. I adjusted the bias pots to eliminate it visually and it sounds pretty decent as is. I know there is a more scientific way to do this, involving math and measuring voltage across emitter resistors. Just wondering if anyone could assist me in figuring out where to measure this and what I should be looking for on this particular amp. Output transistors are 2n3055 and are q30 and q31 on the schematic. Thanks!


2
Amplifier Discussion / Hohner 1250 Question
« on: February 15, 2021, 02:45:05 PM »
Hello All, first post here, but I have been lurking for a while. Was able to sort out a Lab Series L5 with some good information I found on this forum. I know my way around tube amps pretty well, but am still a bit of a novice at solid state stuff. I was recently trying to sort an old hohner 1250 I ended up with. It seems like it's supposed to have a clean and dirty mode which is actuated by a pull switch on the preamp volume pot. When i got the amp it seemed to be in dirty mode permanently with the pull switch doing nothing. I believe the circuitry for this boost is all on a little circuit board attached to the volume pot. I found a schematic for a 1040 and I believe that is what my 1250 should look like as well. I attached that schematic. The little board attached to the pot is outlined in red. The weird thing is that my amp had all the same parts as the 1040 in the red outline, but they were wired up completely differently. My question is, does this schematic make sense? Is that bundle of 4 diodes coming off T101 supposed to go that direction? it was reversed in real life, which makes a little more sense to me. Either the original wiring was wrong, or this schematic is wrong. Or it could be a little of both. Thoughts on the schematic? Should that work? When i wired mine to match the schematic it was pretty quiet and had no switching capability. Thanks!

image_21488

Pages: [1]