Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - txflood

Pages: [1] 2
1
Actually I was wondering if the original 150mA was a good design point in the first place and if it should be increased to say 200mA. I didn't know if there were some good rules of thumb for the worst case draw for these output tubes.

I also got some more info from Ashdown as they have provided the DC voltages in the power supply:

CT   355 v   + /- 10v.
G2   345v    +/-  10v.
HT1   240v   +/-  10v.
HT2   210v   +/-   5v.
HT3   200v   +/-   5v.
A1     215v   +/-   5v.
TP1  ( BIAS )   10v   +/-  0.3v.


2
So getting back to the amp, I was going to try to order a replacement mains transformer but I had a general design question. When considering the current needed for the high voltage section of the power supply, I'm a bit confused as to what the two EL84's will be drawing.

The transformer schematic specifies 270-0-270 VAC at 150 mA. You guys have already recommended trying to find something with a lower voltage if possible, but I'm not sure what we expect the current draw to actually be.

3
I'm just now getting back to this forum and it seems that I have caused quite a stir.  ;)

I read all of the posts last evening and thought about what has been said here. It does make sense to try to match bulb wattage with the device under test and use low wattage when investigating a known faulty circuit. I then thought I would run a few experiments and measure some voltages to try to better understand all this.

First I went back to my known bad mains power supply transformer. This transformer is electrically isolated and disconnected from the amp circuitry. To recap, whenever normal 120V is applied it hums loudly and heats up very quickly and I've only ever tried powering it on for a few seconds at a time. It's bad so I thought a few experiments aren't going to hurt anything.

So I tried using a 40W, 100W, and 250W bulb one at a time to see what happens. In each case, the bulbs turned on as expected and the transformer never made any audible hum and it never seemed to heat up for that matter. I measured somewhere around 35V for what is actually making it to the transformer for the case of the 250W bulb and smaller voltages for the other 2 bulbs.

For US power I would calculate that the fully-heated on resistance of the 250W bulb to be somewhere around 58 ohms. If I am seeing a power drop of 120V to 35V across the bulb then I believe that means we are looking at a current of almost 1.5 amps flowing through the circuit. (All of these are crude numbers but I think they are in the ballpark). So that definitely looks like more power than one would want when investigating a faulty circuit.

The second thing that I tried was then plugging in a good working Peavey TKO solid state bass amp that I happened to have on hand. I believe this amp is rated for a maximum power draw of 200W.

With the 40W bulb plugged in, I measured around 95V being supplied to the amp. With a 100W bulb plugged in, I measured around 108V. With the 250W bulb I was seeing very little voltage drop at all from the original 120V.

So I can see that with an assortment of bulbs this can be used as a "poor man's" variac. It also looks to me that the larger bulbs aren't totally useless either. If you have a piece of equipment and it has been repaired and after applying higher and higher voltages with assorted smaller watt bulbs, wouldn't it still be useful to use a large wattage bulb as your final test where you are supplying as close a value to wall voltage while still having some (although admittedly not great) power protection?

4

I hope this is a typo and you mean 25 watts - the idea is to limit the power into the amp to a safe level, and two-hundred-and-fifty watts is not a safe level.


No actually I meant a 250W bulb. I thought the idea of the device is that if your equipment under test has a short in it, it will still be protected as the light bulb will then turn on and the power will be flowing to it. The large wattage bulbs are required as they have the low resistance needed for this to work in practice.

https://www.youtube.com/watch?v=wRFRwOnLsZI

The best part is about the 7 minute mark when he shorts the circuit with a screwdriver.

 :o

He has a link to his suggested 250W bulb being sold on Amazon.

5
OK so I finally had a chance to get back to the amp. I've built a cool current limiter with a pair of 250W bulbs and tried it on my fried power transformer as a test. It lit up beautifully and the transformer never buzzed or heated up at all, so I would say I now have a good limiter for future repair work.

The only AC source that I had handy tonight output 9.9VAC according to my mulitmeter. Since the transformer is supposed to have 8000 ohms primary for the EL84s to see and the speaker is 16 ohms, I believe that gives us an impedance ratio of 500 and a winding ratio of roughly 22.4.

I applied the 9.9VAC to the primary (with the source plugged into my handy dandy new limiter of course) and expected to get about 0.4V on the secondary. I measured 0.3V and I know my meter isn't the best in the world precision wise so I'm thinking that it's in the ballpark.

You guys were suggesting that I also test it the other way by applying the AC to the secondary, but I'm wondering is that the normal practice for testing an output transformer? Or do you only worry about applying voltage to a secondary if you are dealing with an unknown transformer? I've gathered that it can be frowned on as an unsafe practice or am I misinterpreting things?


6
OK, I made a bad assumption that it was DC resistance so that sounds like potentially good news on the OT.

Thanks for the tips and it will probably be after the holidays before I will have a chance to proceed any further on the amp.

7
I'd guess, the Screen grids are likely getting belted to death.
As you have 270 volt AC supply then your DC at CT is going to be pushing close to 380VDC yet R61 is only 50 Ohms so unless I'm sadly mistaken the power tubes are running way too hard.

Your power amp (V7,4 and 5) is a simple copy of the classic AC30 and they ran 300~320VDC and they were known to run hot. So R61 would need to be raised in value to compensate for the higher supply voltage.
You can see signs of over dissipation by looking at the plates of the power Valves, those little holes in the side of the plates. If there is any sign of black burn marks around those holes it's a fair bet they have been flogged to death.

The amp I have is the 20W version so R61 is 100 Ohms  and V8 and V2 are not fitted if that makes much of a difference.

I took a look at the output tubes and didn't see any black burn marks but maybe I don't know what I am looking at. The guy I got the amp from claimed all the tubes had low hours on them as well.

Obviously the power tranz is dead so maybe look for something lower than 270 VAC as a replacement.
This issue of higher than needed HT voltage is common and from what I understand some transformers were likely meant for valve rectification where there is a lot of voltage drop across the rectifier Valve but with SS diode rectification the drop is only small so the working voltage gets bigger and without a rethink of power valve conditions and rebiasing the power tubes suffer greatly.

Valves are tough and can handle over voltage by a fair amount but NOT over current. So the higher the voltage the more critical the dissipation becomes. The screen grid is the weak link in power Valves and is a common failure mode.
OK thanks for that info. What I am taking away from this is just how well thought out is this amp design and does it need changes to actually make it reliable. I don't know enough about valve amp design to know what corrections are needed here but I am willing to learn.

Regarding a new transformer, just take the secondary voltage and multiply it by 1.414 (1.4 is close enough) that will give you a clue as to the DC result.
That voltage will drop when running so if the equation runs out at 320~330 VDC it will be close enough.
Keep at it, if you take time to work through it I see it as a worthwhile fix. :tu:
Phil.


So you would recommend a replacement power transformer that is more around 220V (if I did my math right) as a good design point?

Well at this point I am guessing that both transformers are going to have to be replaced as my initial cost factor, but this looks like it might be a good learning experience and hopefully I end up with an amp I actually might want to use.  :)

8
There seems to be some confusion here between the power transformer (PT), mains to rectifier, and the output transformer (OPT), output valves to speaker.

Right I was initially going by what I was told before ever looking at the amp.

An important early check are the main rectifier diodes, <peacemaker-40-b.pdf> D10-13.

Those tested fine using the diode check on my meter.


Here's a radical idea - test the OPT.

Fully isolate it and apply around 6.3VAC to the speaker side.  It will have a turns ratio of around 20:1-30:1 so you should get something like 20 * 6.3 = 126VAC to 30 * 6.3 = 189VAC on the anode side.  The exact voltage isn't that critical, but if it's very much lower then it suggests that the OPT has a shorted turn, otherwise it suggests that it's okay.
Thanks for this tip. I did get the specs from Ashdown now on the OPT and I'm guessing that it is bad as the drawing shows 8K ohms resistance on the primary windings. I am measuring a little less than 600 ohms.

Wouldn't this low primary resistance explain R76 burning up feeding the CT of the OPT?


Until you are sure all is well you should only power up the amp via a Limiting Lamp.
I was already thinking that I should have one of these when I attempt to replace the power transformer and energize the circuit.

Thanks for the info!

9
This was a buddy's amp that he had a tech look at a few years ago and was told the "output" transformer needed to be replaced. I now have the amp and took it apart.

The tech had left the wires from the power supply transformer disconnected from the PCB so I started there to see where things really stand with this amp.
The AC inline fuse was blown and I found scorched marks around R76 in the power supply section on inspecting the PC board in detail. There is a wire that runs from the power supply at R76 to the center tap of the primary side of the output transformer. The connector is attached where the board silkscreen reads "FROM OUTPUT TX" next to R76 and the plastic insulator on the connector appears melted. R76 sits between the 2 filter caps and it does measure to be 470 ohms.

I also removed the PCB from the chassis and took a look at the area under R76. It looked like the solder had been worked on that resistor so I am guessing that the original part has been replaced. Close inspection showed that the current resistor has a 6W power rating while the schematic only calls out for 2.5W.

I disconnected all the leads from the mains transformer to the PCB and then took no load AC measurements on the secondary winding wires coming directly from the transformer. I only applied power for short intervals. The transformer buzzed fairly loudly and got warm fairly quickly even with these short tests, so I knew that wasn't a good sign already.

On the high voltage pair I only measured around 10VAC. The yellow pair only came in at 6.6VAC and the red pair at 4.8VAC. I would say this confirmed my worst fears on the power transformer.

So the question remains as to why that resistor failed and if it took the power supply transformer out with it or if that occurred later.

I contacted Ashdown and they don't have replacement power transformers but they did give me the specs on the three secondaries:

270V @ 0.15A
6.3V @ 1.6A
13V - 0 - 13V @ 0.5A

I couldn't find an off-the-shelf part to match all 3, but I found a few candidates to match the first 2:

Hammond 270FX, Weber W025130INT, or maybe Weber WPTGP (that one would be 280V)

My thought is to get one of these transformers and then add another small transformer to the chassis to take care of the 13-0-13V.

I also tried to test the filter caps to make sure there wasn't any obvious problem (visual inspection, low impedance) but could not find anything. The PCB indicates the amp was assembled in 2002 time frame so I'm thinking it would be a good idea to replace them anyway.

I'm still concerned that perhaps there is still a problem that caused the power supply failures in the first place that hasn't been addressed so I was going to proceed carefully when trying to re-energize the circuit after getting replacement parts.

Since I've never actually heard one of these amplifiers, I am curious as to what it really sounds like and how they are regarded in general. I haven't found much info on them at all.

10
I was looking for advice on where one could find a suitable output transformer for an Ashdown Peacemaker 20 amp. It has EL-84 output tubes and the schematic can be found online here if needed:

http://music-electronics-forum.com/t34072/

I was wondering how cost effective this repair would be for this particular amp.

Thanks

11
Amplifier Discussion / Re: Behringer Ultratone K3000FX
« on: September 08, 2014, 12:44:38 PM »
Thank you!
 :dbtu:

12
Amplifier Discussion / Behringer Ultratone K3000FX
« on: September 07, 2014, 04:03:47 PM »
Anyone have the schematic for this keyboard amp?

Thanks

13
Amplifier Discussion / Re: Heatsink questions on Crate
« on: March 26, 2013, 08:02:31 PM »
It is a mute, it shunts the INPUT signal to the power amp.   It can do absolutely nothing about the power amp's power up thump.

Right, so the idea is that the transistor switch grounds the input (preamp output) going to the power amp until some time after the power amp is fully powered up. This would be governed by the RC time constants of the transistor circuit, correct? Just trying to learn.

Also I confirmed that the DSP board has 4 plastic standoffs. The only ground comes from pin 3 of the connector.

14
Amplifier Discussion / Re: Heatsink questions on Crate
« on: March 26, 2013, 02:21:30 PM »
Q16 Q31 are just a power amp mute.

So this circuit is there for power on muting then, correct? Right now even with the standard C64 1000uf cap in place there is a pretty good speaker thump at power on time.

15
Amplifier Discussion / Re: Heatsink questions on Crate
« on: March 26, 2013, 08:58:46 AM »
Sorry I didn't look more closely at the previous schematic that was posted. Dr Gonz has posted the correct one now.

I believe on this amp there were 4 plastic standoffs in each corner of the DSP board so I don't remember any kind of chassis ground connection or screw. I will take another look this evening.

Pages: [1] 2