Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bsantos

Pages: [1]
1
Amplifier Discussion / Re: Rocktron Rampage R80
« on: June 25, 2020, 08:33:55 AM »
Thanks for the suggestions!
Regards

2
Amplifier Discussion / Re: Rocktron Rampage R80
« on: June 23, 2020, 05:46:43 PM »
Hi again,
So, I tried the cord between the send and the return jacks and it worked! Thanks for the tip!

While this is certainly a good workaround, how would suggest to fix this? This may.simply be related with some dirt in the connector. So, replacing it may be a bit of an overkill. Any suggestions on how to clean it up?

Since I have the amp opened and the PCB's are exposed, would you suggest any procedure to avoid other issues, like cleaning it up?

Thanks and regards,
Bruno

3
Amplifier Discussion / Re: Rocktron Rampage R80
« on: June 22, 2020, 05:28:35 PM »
Hi there!

Thanks, will try the patch cord tomorrow.
I did contact Rocktron support but I have no reply so far.

Thanks and regards,
Bruno

4
Hi @strombringer

Did you ever get to fix the issue?
I have exactly the same problem on my R80.

Also, did you find the schematics?

Thanks and regards,
Bruno

5
Amplifier Discussion / Re: Rocktron Rampage R80
« on: June 22, 2020, 07:47:01 AM »
Hi @jamie5152,

Were you able to get the schematics? Could you please post it here?

I have this very same amp, for a long time, since 1999, I think. Eventually it started to show this problem: it randomly shuts down the input signal and there's  no sound out of it. After some time it recovers. Also, if I turn it off and on again it stays fine for a while. It has been in a shelf for years and now I am trying to fix it. But without the schematic it's tough.

Would really appreciate if you could send me the schematics.

Thanks and regards,
Bruno

Pages: [1]