Solid State Guitar Amp Forum | DIY Guitar Amplifiers

Solid State Amplifiers => Amplifier Discussion => Topic started by: Sara2020 on July 23, 2020, 10:34:07 AM

Title: Crate G130C Amp
Post by: Sara2020 on July 23, 2020, 10:34:07 AM
 Hi Everyone, I have a Crate G130C Amp that I bought new in in the mid 90's. At some point I started having an issue with the Amp where the output sound would fade out. If it would cool down, it would temporarily start working again. I sent the Amp in to SLM Electronics / Crate, in St Louis, Missouri and they fixed the issue. It worked fine for many years but has developed the same problem again. As you probably know, they have went out of business. I took the circuit board out of the Amp and have replaced a few resistors that had split open from overheating,but that didn't fix the main problem. I recently found the paperwork that SLM Electronics sent me when they repaired the Amp before. It says that they had replaced a "Leaky Zener Diode for the low voltage power supply"  They unfortunately didn't put a part number for the Zener Diode on the invoice. I have ran across the schematics for this Amp but I can't tell where the Zener Diode is for the low voltage power supply. Could someone please help direct me to where the Zener Diode is located on the circuit board?
Title: Re: Crate G130C Amp
Post by: Jazz P Bass on July 23, 2020, 11:51:25 AM
Piease post the relevant schematic.
You really should test the power supply before assuming the failure mode is the exact same.
Title: Re: Crate G130C Amp
Post by: Enzo on July 23, 2020, 01:26:58 PM
And the factory doesn't need to be there, ANY competent amp tech can repair this.  I bet you have a local shop.

I surely wouldn't assume the same zener needs replacement.  It MIGHT of course, but frankly it is more likely your FX loop jacks have dirty contacts.
Title: Re: Crate G130C Amp
Post by: g1 on July 23, 2020, 02:20:44 PM
schematics/service manual attached.
Title: Re: Crate G130C Amp
Post by: Jazz P Bass on July 24, 2020, 12:51:35 AM
To answer the posts question, here is a crop of the power amp board locating D16 (+16Vdc) and D17 (-16Vdc)
Title: Re: Crate G130C Amp
Post by: phatt on July 24, 2020, 02:14:45 AM

Quote;
* At some point I started having an issue with the Amp where the output sound would fade out.*
Then,,
Have you checked your FX loop? a common cause of intermittent signal drop out.
Phil.