Welcome, Guest. Please login or register.

April 14, 2021, 11:02:22 PM

Login with username, password and session length

Recent Posts

 

Author Topic: 1967 Mosrite BG-500 Output Transistor Bias Question  (Read 417 times)

lovatomi

  • Chipper
  • *
  • Posts: 8
  • Chip Points: 0
    • View Profile
1967 Mosrite BG-500 Output Transistor Bias Question
« on: February 21, 2021, 09:45:19 AM »
Hi all. I have an old Mosrite SS amp that I am working on getting back into good working condition. It had a few blow transistors in the output stage (as well as a couple light bulbs?!) and I have replaced the suspect parts. When i fired it up and scoped it i noticed I was getting a fair amount crossover distortion. I adjusted the bias pots to eliminate it visually and it sounds pretty decent as is. I know there is a more scientific way to do this, involving math and measuring voltage across emitter resistors. Just wondering if anyone could assist me in figuring out where to measure this and what I should be looking for on this particular amp. Output transistors are 2n3055 and are q30 and q31 on the schematic. Thanks!


g1

  • Legendary
  • ******
  • Posts: 708
  • Chip Points: 87
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #1 on: February 21, 2021, 08:12:02 PM »
Each of those 2 output transistors has an emitter resistor.  It's too blurry for me to read the numbers but it looks like they are .1ohm 5watt.
So with load connected but no signal, measure the DC millivolts across each of them.  Calculate the current through each (V/R).
Mostly you will want to check that they are balanced, and that the current is not excessive.
Not sure exactly what that number would be, but if you post your results any problems should be apparent.

lovatomi

  • Chipper
  • *
  • Posts: 8
  • Chip Points: 0
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #2 on: February 21, 2021, 09:55:39 PM »
Thanks G1. Yes, they are 0.1 ohm resistors. When I checked one was at about 25 mV and the other was at 0. I adjusted them both to be about 25 mV. I suppose that would mean they are seeing 250 mA of current. Is there a current number I should be shooting for? The bias pots allowed for a sweep of about 0-50mV. Thanks!

Jazz P Bass

  • Elite
  • ****
  • Posts: 274
  • Chip Points: 21
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #3 on: February 22, 2021, 11:55:14 AM »
The output topology is Class A/B.
So with no current reading across the emitter resistors, the amp is in Class B.
Fellow member Enzo has an excellant old school method of setting the bias.
-Measure the current draw from the mains while turning the bias trim pot.
When you start to see more current being drawn, the amp is now entering the Class A part of A/B.
Turn the trim pot back down a tad and you are done.-
There is not a 'specific' current draw across the emitters that can be stated.


teemuk

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 1075
  • Chip Points: 282
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #4 on: February 22, 2021, 12:05:12 PM »
Right. And verify that bias doesn't start to climb along with operating temperature. Back down if it does.

g1

  • Legendary
  • ******
  • Posts: 708
  • Chip Points: 87
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #5 on: February 22, 2021, 01:23:25 PM »
I adjusted them both to be about 25 mV. I suppose that would mean they are seeing 250 mA of current.
That is pretty hot (around 8watts), about 5 to 10 times what I'm used to seeing.  They probably feel fairly warm after on a bit.
Unless that is a typo or measurement error (or resistors are not actually .1 ohm).
3 to 5mV across a .1ohm would be more like it (30 to 50mA idle current per output device).  You will need a decent meter to measure that.
See if you can get a low setting and still not see the crossover notch.

lovatomi

  • Chipper
  • *
  • Posts: 8
  • Chip Points: 0
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #6 on: February 22, 2021, 05:09:32 PM »
Thanks all! I discerned after a a little research that 50mA might be a safer current draw, so I reset the voltage across the emitter resistors to about 5mV. I have a pretty good meter (Fluke 115), but even that can't tell my anything about how close 0.1 ohms I actually am!

I will give the "Enzo" method a try. Stupid question, but when you say measure the current draw from the mains would replacing one of the fuses on the ac side of the PT with my meter reading amps be an acceptable way to do that? I assume when you get to the part when you "turn it back down a tad" you are trying to hit the point right before it begins drawing more current? Thanks again!


lovatomi

  • Chipper
  • *
  • Posts: 8
  • Chip Points: 0
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #7 on: February 22, 2021, 07:40:46 PM »
OK, using the guidance above it seems like the amp wants about 4.3 mV across those .1 resistors. With it set like that, frankly the amp sounds fantastic. Better than I could have hoped! Really sparkly clean. Then of course I go to switch on the tremolo/vibrato circuit and it starts screaming/oscillating like a madman. This was working pretty good before. Any chance my fiddling with the output transistors caused this? Is there a way to unfiddle it?

lovatomi

  • Chipper
  • *
  • Posts: 8
  • Chip Points: 0
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #8 on: February 22, 2021, 11:41:28 PM »
Ha... never mind... crazy oscillations when trem engaged was caused by the reverb input jack touching the chassis. Who knew?! Everything sounding quite good now. Fingers crossed.

g1

  • Legendary
  • ******
  • Posts: 708
  • Chip Points: 87
    • View Profile
Re: 1967 Mosrite BG-500 Output Transistor Bias Question
« Reply #9 on: February 23, 2021, 02:16:20 PM »
That idle current number sounds more reasonable.  Good job.   :)