Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

May 27, 2024, 06:43:56 PM

Login with username, password and session length

Recent Posts

 

Mesa Dual Rectifier

Started by Psabin8951, May 12, 2024, 06:11:36 PM

Previous topic - Next topic

Psabin8951

I have a problem with a multi watt dual rectifier head.
It keeps blowing fuses and a rectifier tube.
Using the light bulb mains lead method, even with both rectifier tubes out of the unit and on standby it seems to be drawing quite a bit of current. No change with power tubes also removed.
Is this likely to be the large filter caps going or any other suggestions?
Thanks in advance

DrGonz78

#1
If the rectifier's are not in circuit then there would be no B+ vdc. So I can't immediately imagine the caps are the issue from that standpoint. Of course posting a schematic would be a good thing. It seems the transformer may have other windings -/+15v rails and your heater's winding. Try disconnecting all secondary connections when in doubt. Light bulb shining with secondary taps disconnected from circuit is not good. Right now from what you have written we need to clarify what you are describing and a schematic. We need voltage readings if the light bulb is not shining bright.
"A person who never made a mistake never tried anything new." -Albert Einstein

Miyagi_83

#2
Hey, Psabin8951,
I'm no expert, but a couple of things popped in my mind.
Which fuses does it blow - primary or secondary?
As I understand Mesa Dual Rectifiers, it should have a rectifier selector switch. Does the amp do that with solid-state rectifier selected?
Could it be a short on the primary side of the power transformer? 🤔
Like DrGonz78 said, a schematic and voltage readings would help.

You need to be super careful and you must know what you're doing if you ever decide to tinker with it yourself. As you probably know, there are lethal voltages inside that thing. If uncertain, take it to a tech.