Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

June 27, 2022, 04:38:59 PM

Login with username, password and session length

 

Blackstar ID Core 40 'Bricked' Problem

Started by Clyde, July 20, 2016, 05:14:59 PM

Previous topic - Next topic

Clyde

It lives!
I was able to get my hands on a working IDCore 40 & after using Flashrom/Serprog to read the data on that amps serial mem chip & writing same to the 'dead' amp it powered right up.  That's the good news.

Bad news is that the speakers are stone dead.  But... the headphone jack & USB ports work as advertised, allowing me to run thru the various amp functions using headphones or into a PC/DAW.  Also was able to log into the Blackstar 'Insider' site & performed a successful firmware upgrade. 

For speaker output the amp uses a TDA7491HV 20+20w class D audio amp & from the datasheet it appears that it is stuck in standby mode with a ground sitting on stby & mute pins (PowerSSO-36 chip).  And reverse engineering this w/o schematic is problematic at best.  But I'm still chasing things.

All about tinkering & learning for me.


galaxiex

Kudos you got it working!  8)

When I started following this thread I thought "good luck!" but this just shows what perseverance will do.

Tip of the hat to you sir!
If it ain't broke I'll fix it until it is.

Clyde

Thanks for the comment Galaxiex.   Hopefully this might help others out there with the same issue.  There is hope.

Now if I can get a grip on the speaker problem I'll be 'done' with this.  If I prove it to the audio amp I'm not exactly looking forward to the replacement process.  Still...cool challenge trying to get it 'right'.

Scouser72

Hi Clyde,
I have exactly the same issue with a secondhand ID:CORE stereo 40.  Could you expand on what you did to use Flashrom/Serprog to read the data on that amps serial mem chip & writing same to the 'dead' amp it powered right up and share the binary you read using Flashrom/serprog?

dlbraly

This is an old post, but pretty neat YouTube video you linked.
Clyde,
I would also be interested in hearing more details on what you did.

Myhigh

Hello..does someone know how to read binary files,add binary files to an amplifier,I have the same problem with my blackstar Id core 40..I did a firmware update and now it won't restart..no responsive,no lights on anywhere..Clyde said he read the chip on the board from an other amplifier and copied the binary file onto his bricked amp and got it going