News:

The SSGuitar.com web store is now online!  Check it out at https://store.ssguitar.com !

Main Menu
Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Topics - FenderDeluxe112Plus

#1
Amplifier Discussion / Fender 112 Deluxe Plus
April 12, 2022, 04:39:01 PM
Hello, this is my first time posting on the forum, I have been using related posts on here to help me so far.  Apologies if I have posted this in the wrong place.

I have a Fender 112 deluxe plus that was blowing the internal 2a fuse on start up. The amp was also making a very loud buzz with all volumes at 0.
I disconnected the speaker and checked the output transistors. I found a shorted pair of tip142/tip147 so I replaced all four transistors using new micas and heat compound.  I pulled and checked the heatsink diodes which all tested ok with multimeter. I also replaced the .47 emitter resistors for each output transistor.  I checked the diodes in the power supply and Qs 3-9.

The channel switching was also playing up - turning on the clean and overdrive channels at the same time. I replaced the u4 ic after finding it shorted with a new 4560D and powered the amp up with a light bulb limiter. This seemed to have solved that problem and the channel switching works again. The bulb was glowing very dimly with no sign of shorts  and fuse not blowing, so I powered off and reconnected the reverb pan - still all good. Then I powered off and reconnected the speaker - the amp is still making the same very loud buzz. I have gone through the entire board with a multimeter checking for continuity between each solder joint and all seems well. I reflowed the solder on a number of joints including the filter caps just to be sure. The 4 ohm speaker measures as 3.97ohms, so I assume ok. Could this be filter cap/power supply cap related or an issue with the transformer? Or am I missing something else e.g. switching issues in the jacks? I know these amps are not worth much but I would like to get it running again.
Any help would be greatly appreciated!

Thanks,

Andy


https://www.vintageshifi.com/repertoire-pdf/pdf/telecharge.php?pdf=Fender-Deluxe-112-Plus-Schematic.pdf