Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

February 21, 2024, 04:46:10 PM

Login with username, password and session length

Recent Posts

 

Ibanez Troubadour TA 25 toasted output transistors

Started by Felixl, November 19, 2023, 09:24:54 PM

Previous topic - Next topic

Felixl

Hey, just bought a Troubadour amp for a few dollars. Owner told me it started to make smoke when he lit it.
I tested it. Both output transistors TIP41 and TIP42 were toasted. The TIP showed obvious burn marks. I replaced them and the amp seemed to work. But...
I later noticed that two .5 ohms resistors had been removed. Oddly, those where the resistors (see R223 and R223on schematic) connecting both TIP's emitters. So without those resistors both emitters were connected to nothing. But still, I got sound from the amp. It seemed to work, only maybe the input too sensitive and a tendency to distort if the guitar volume was too high. I wasn't sure if this is because the amp was designed only for mikes and acoustic guitar pickups.

Question 1 : Is it normal that the amp still makes sound if the emitters are not connected to anything?

Realising the 2 resistors were missing and guessing this might be why the TIP were toasted, I put back the two missing .5 ohms resistor exactly where there are on the schematic, no mistake possible, you can't miss the spots on the PCB.

And then : smoke!!! One of the resistors burned out and the TIP42 was fried.

I re-replace the TIP42 and took out the resistors and it seems to work. Or does it??

Does anyone knows what can be the cause of this? Thanks


SCHEMATIC :  [/img]


Tassieviking

I would guess that the sound you are hearing is not very loud ?
You most likely are generating the sound with Q205, and possibly Q208.
It would not be very loud because it goes through the 100 ohm resistors to the output.

At a wild guess I would say that Q208 is bad and its driving the TIP42 fully on.
With the 0R5 resistors removed and amp on, do you have any DC output to the speaker ?
Disconnect the speaker and measure the output again, it should be very close to 0 volts if everything is ok.

Are the +32 and -32 volt rails ok ?
I presume the TIP transistors have good insulators behind them, check with a meter.

Without the resistors in the amp the TIP transistors are not doing anything and the amp would not be working very well at all.
A 25 watt acoustic amp would be fairly loud.
There are no stupid questions.
There are only stupid mistakes.

Felixl

Thanks.

What's really weird is that it sounds as loud as like a normal amp.

The 32v rails are 31,8ish. TIP Isolation seems ok, I checked, but will recheck.

I'll have a look at the output DC voltage and check Q205 plus all other transistors.

Really wonder why those resistors were taken out. They were tie wrapped on the heat sink like spare parts.

Felixl

After checking every transistor caps and what not, desoldered Q205 and q208 and a few others and checked them (they were ok), I put everything back in place (including R222 and R223) and guess what, the amp works just fine, no smoke, no excessive heat, and way more powerful than before.

So the sound I was getting before was from Q205-208 alone.

It's always fun to fix stuff. But not getting why? Not so much because i'm fairly new to this and I want to learn.

What could have happened? I see 2 possible reasons that caused everything to blow up when I first powered it up after replacing TIP41-42 and resoldering R222-223.

1- I discovered that a BNC cable I bought on Amazon was shorted. I'm not sure if it was connected to my dummy load box (bnc being connected directly to spker input). It could have shorted my amp output.

2- When I re-soldered Q209 (I think) I didn't first saw that I reinstalled the heat sink (see pic of the heat sink installed correctly) the wrong way and that all pins were touching the heat sink, thus connecting them to ground. But I'm not certain the heat sink was in place when I powered up the amp. Could this have caused R223 to smoke and Q207 to fry?

Anyway, it's now working. And the reason R222 and R223 where not in place when I first took a look an the amp is still a mystery to me.




   


g1

The only way Q209 heatsink could have been responsible is if only the base and emitter were of Q209 were shorted together.  This would set the bias even hotter than the factory trim pot allows, as the R226 resistor would be shorted out.

I think it's more likely that the shorted cable was responsible, or there was a solder problem that got fixed in your re-soldering process.

saturated

congrats on the fix nice work

I used to have one I found it on the curb and it was missing an input jack so I replaced it and it worked good.

You cannot view this attachment.

I always had plans to get an acoustic electric but never did

so really the only thing I ever played on it was "back on the chain gang" because it had a nice sparkly sound

 :)
I ask stupid questions
and make stupid mistakes

criticism, critique, derision, flaming, verbal abuse welcome

Felixl

There is still a thing that I almost forgot. While I was inspecting the amp I was getting funny readings from the trim pot and decided to replace it... Not knowing what I was getting myself into.
Now I have to adjust the bias and there is nothing specified in he service manual. I've worked mostly on tube amps so far, and I have the gear to adjust tube bias.
But from what I understand, this is factory-set and thus rarely covered in manuals.

Does anyone know how it should be done? Thanks.

g1

With unit cold and load connected, I would adjust so you have no more than 5mV DC across each of R222 and R223.  That would equate to approx. 10mA idle current through the output devices, which should be plenty.  Even 3mV should be enough.
Alternatively, if you had a scope, at low level signal output into load,  you would reduce the idle current till you see a crossover notch, then increase it till the notch just disappears.

Felixl

Yes I have an oscilloscope. I'll try all those methods. Thank you so much!

Very happy to have found a place where I can be surrounded by such skilled people. :)