Welcome, Guest. Please login or register.

January 28, 2022, 10:31:17 PM

Login with username, password and session length

Recent Posts

 

Author Topic: Randall Century 100 schematics?  (Read 1729 times)

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #30 on: January 16, 2022, 03:21:58 PM »
Alright, here's another backlit photo. Hopefully it's a little clearer. I labeled the pot connections and such.

I redid a couple of soldering points on the pots, like on the treble pot, and it removed the sensitivity but not the buzz.

I figured signal tracing is pointless if the noise can be coming from anywhere downstream of the reverb tank. The noise would likely show up everywhere past that.

So then, apart from the input jack, which may be part of the problem, I'm looking for places that should be grounded but aren't, correct? Spots that have voltage potential on the ground trace, where it is not supposed to be? So I can go around testing all the ground points against a known good one, looking for potential?

« Last Edit: January 16, 2022, 04:58:20 PM by cin »

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #31 on: January 16, 2022, 05:56:16 PM »
I apologize for the many posts. I imagine I am as confusing as I am confused.  :dbtu:

I've been reading about ground loops, and if I understand correctly having many paths to ground is bad because there can be potential differences between the many points, which would cause current flow between the two. But how can there a be differences in potential between two points that are connected? Which is why I concluded that I was looking for a disconnect in the ground.

I thought I'd trace it out on my photo of the circuit, to make it easier to test everything. I also traced out some parts of the circuit that are not obvious in the backlit shots.

Ground in blue, missing circuits in red, yellow dots are the pins of the power amp. It's very likely wrong in some places, I can see spots where it may not make sense, like that ceramic cap in the middle that's not connected to anything??

« Last Edit: January 16, 2022, 05:58:55 PM by cin »

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #32 on: January 16, 2022, 07:27:37 PM »
I've gone back over what I thought was GND with my multimeter, and made some corrections to the image (attached). I've also made some corrections to the live circuit in red. And I've added, in dark blue, all the places I've checked to be <.4 Ohm when compared to the yellow common wire at the chassis (ie properly grounded?). Again, I'm assuming this means those spots can't have unexpected voltage potential, unless the chassis isn't grounded.

Where else should I check?

« Last Edit: January 16, 2022, 07:36:58 PM by cin »

phatt

  • Legendary
  • ******
  • Posts: 2237
  • Chip Points: 286
    • View Profile
Re: Randall Century 100 schematics?
« Reply #33 on: January 16, 2022, 07:48:47 PM »
Great work you are doing well. :tu:

Ok isolating the in socket reduced the hum so you know ground path is an issue.
I did look at the first PCB pics again last night and Yes there are many ground paths. ouch!
It's likely that this being a budget model there was no R&D done so the issue may well be a factory fluff up,,, I've seen that a few times even in higher end products.

I've got things to do today but later tonight I'll edit some of your pics with possible re routing of the ground paths.
thanks for the new pics it will help us understand just where all the ground paths run.

the issue of ground loop hum is not the voltage diff but more about *high Current and low Current* mixing in the wrong place. Input ground path is very sensitive and can be easy pick up the hum if the ground paths mix.
something like that,,better minds will explain it better. lol.
More tonight, Phil.

phatt

  • Legendary
  • ******
  • Posts: 2237
  • Chip Points: 286
    • View Profile
Re: Randall Century 100 schematics?
« Reply #34 on: January 17, 2022, 12:15:49 AM »
Before we go rewiring the whole ground path, just start with one mod at a time, that way you can assess progress.
Ok isolating the input socket has helped so leave it isolated and Re route that Yellow Com wire
to the Common/Ground junction of the 2 main filter caps on the PCB. (see pic)
You will need to drill a hole for that wire and scrape off the lacquer to solder it.
(while you are there drill 3 holes as you may need it for other mods).

Note the common junction of the main filter caps becomes Com 1, ideally every other com point
should go back to Com1 on a separate path and then Com1 junction is wired back to the chassis
case. (where the yellow wire was) Don't worry about inserting a chassis wire right now as the PCB
is already grounded via the mounting posts and could lead to more problems.
I'm just saying this to show you how it should be done.
Google star grounding for clues.

Rewiring the yellow will alter the Current path and might be enough, if not then you may have to alter the path for com 2. (blue wire on picture) At the moment it seems to run all the way around the out side of the PCB then back to Com1,, which is not a good design. xP
To do the Com2 rewire you will need to cut a pcb track so meantime, Can you tell me if the ground trace runs all the way along the front edge of the PCB and back around to the main filter caps?
I can't clearly see the front edge with all the pots . It looks like it does but i need to be sure.

So Yellow wire mod first and see if it improves,, then move on from there. :tu:

You seem keen to learn so maybe sit down and draw out the whole schematic,, ,yeah it will be slow but you will learn a lot.
BTW, be aware electronics can be very addictive. :duh
Phil.

phatt

  • Legendary
  • ******
  • Posts: 2237
  • Chip Points: 286
    • View Profile
Re: Randall Century 100 schematics?
« Reply #35 on: January 17, 2022, 12:34:42 AM »
Oh adding this to show the idea of ground paths in amplifiers.
Note, How Com 1 is the Central Com point for the whole Amp, High current paths come first (The Lm1875)
THEN the low current paths from the sensitive inputs come last and preferably on separate tracks.

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #36 on: January 17, 2022, 12:59:08 AM »
Amazing! I'll review all of this carefully tomorrow.

Moving away from looking for faults, and into changing the circuit, pre-supposes that the amp is basically buzzy by design. It is a fairly low-cost unit, and it shows in the simplicity of the circuit compared to other amps I've seen, but I'd be unimpressed if it came out of the factory sounding like that. The buzz is about as loud as an electric toothbrush at any volume (a very scientific alternative unit to the decibel), it pretty much makes the amp unusable at anything lower than "quite loud" (like 500 or so electric toothbrushes).

I was also hoping to bring back the amp to a working state while removing all the modifications to make it as close to the original as possible. I won't be keeping it, and it's a lot easier to sell an amp that sounds good and has just been re-capped, than one with mods.

That being said, the primary objective is to get rid of that buzz. And bettering a flawed design is appealing. But I'm wondering if there isn't still a fault somewhere, other than a bad design. I can test re-routing the yellow wire to one of the cap's ground terminal without having to drill anything, so I'll try that to see if that does it, and report back.

Again, many thanks for the patient guidance and knowledge.

phatt

  • Legendary
  • ******
  • Posts: 2237
  • Chip Points: 286
    • View Profile
Re: Randall Century 100 schematics?
« Reply #37 on: January 17, 2022, 07:09:28 AM »
If the amp makes exceptable sound and all the controls work as one would expect then it's highly unlikely there are other faults. 8|

The fact you isolated the input and found it reduced the hum tells you the issue is most likely a ground path problem.
And after studying the pcb pictures it's a poor layout and I'm not surprised it has a hum.
As far as mods go without another Amp or schematic of same you have no way to know what was stock. ???

If your intention is to sell it then just fix the hum and don't waste your time.

If you keep it and use it as a learning tool it will help you down the track. :-X

Long before I fully understood Amplifiers
I once had a little 10 watt amp and tried to modify it. By luck more than brains I fluked it into a great little sounding amp. For the first time I actually sounded like Clapton with my strat.

Silly me sold it for another rig that had reverb but I never drew up the schematic. I still regret not keeping it and drawing up the circuit before I sold it. That was 40 years ago and I still regret it now. :-[
Phil.

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #38 on: January 17, 2022, 11:16:25 AM »
Well, my primary intention is to learn, and this little amp has been great for that so far... with your coaching that is.

But once I'm done it's got to go. I only have so much space, and I have another amp that I prefer (for now). So the plan was: repair it if I can, make it as close to original as possible, resell it.

But I hear you, it'll be hard to bring it back to the original state without the schematics or another one to compare to. There's another forum where I've found some hard-to-find schematics before.... music-electronics-forum.com I'll check there before giving up on the original design.

Will test the yellow wire re-route in a bit. I'm assuming I'm leaving the green earth-ground wire coming out of the power cable tied to the chassis here, for safety?
« Last Edit: January 17, 2022, 11:21:59 AM by cin »

cin

  • Regular
  • **
  • Posts: 23
  • Chip Points: 1
    • View Profile
Re: Randall Century 100 schematics?
« Reply #39 on: January 17, 2022, 07:50:35 PM »
I've rerouted the yellow common wire to one of the power cap's ground leg and the buzz is gone!

And that does look like an elegant enough solution to my problem. I'll just have to do a good job at wiring the new ground path, so it looks all pro and such.

Splendid!

This is great news for the amp, but above all else it's what I've learned along the way... That sounds cheezy.
But you get what I'm saying. Thank you for showing me the way there. I now have a much bigger bag of tricks to attack my next amp project with, thanks largely to you.

This is certainly very addictive. Pretty sure I got some endorphins when I flipped the switch and the noise was... not there! very good.

Cheers!
« Last Edit: January 17, 2022, 07:52:35 PM by cin »

phatt

  • Legendary
  • ******
  • Posts: 2237
  • Chip Points: 286
    • View Profile
Re: Randall Century 100 schematics?
« Reply #40 on: January 17, 2022, 08:38:36 PM »
Great to hear you have resolved the issue, I know how hard it is to understand the intricacies of these things when you are new to it all. :dbtu: :dbtu:
And YES leave the Mains Earth wire connected to the Chassis, It's always the first thing I check when working on gear.
Keep at it, the next time you have a bad hum you will know what to look for :tu:
Phil.