Welcome, Guest. Please login or register.

July 24, 2021, 11:23:56 PM

Login with username, password and session length

Recent Posts

 

Author Topic: Roland Jazz Chorus 50 troubleshooting  (Read 395 times)

syndromet

  • Elite
  • ****
  • Posts: 198
  • Chip Points: 38
    • View Profile
Roland Jazz Chorus 50 troubleshooting
« on: June 14, 2021, 01:54:32 PM »
Hi, guys.

It's been a few years since my last visit, and I'm happy to see the forum thriving.

A few weeks ago I was lucky enough to catch a guy in the act of throwing a pristine looking 1981 Roland Jazz Chorus 50 in the dumpster. I managed to stop him, and brought the amp home with me. However, not all is well inside this thing. The JC-series is known for their clean sound. This one will break into some nasty sounding distortion, even when playing soft with weak single coils. If I turn the guitar volume down to almost zero it does not distort, so it does react to dynamics. Also, the chorus effect and the reverb is not working. The Vibrato works as it should. Plucking the springs in the reverb pan comes thru loud and clear. All other controls seem to do what they are supposed to to.

The amp uses the same circuit as described in the second half of the service manual found here : https://www.synthxl.com/wp-content/uploads/2020/01/Roland-JC-50-SERVICE-NOTES-2nd.pdf

Here is a little video of the amp, showing the distorted sound.
https://photos.app.goo.gl/zvWB812VUS7bAtHz6

There is no sign of bad solder joints, burnt components or bulging caps. I will recap this thing, but I want it up and running first. I don't think the problems are caused by gone electrolytic caps.
As far as I can see from the schematic, there is no logic in that both the reverb and chorus not working. Can anybody take a look at the schematic and help me with where I should start troubleshooting?

Den.

  • Regular
  • **
  • Posts: 44
  • Chip Points: 0
    • View Profile
Re: Roland Jazz Chorus 50 troubleshooting
« Reply #1 on: June 14, 2021, 06:29:51 PM »
Have you tried plugging the speaker out into a known good speaker/cabinet?

Jazz P Bass

  • Elite
  • ****
  • Posts: 296
  • Chip Points: 23
    • View Profile
Re: Roland Jazz Chorus 50 troubleshooting
« Reply #2 on: June 14, 2021, 07:01:26 PM »
The Reverb not working could be a faulty wire or transducer in the receive side of the tank.

The Vibrato working means that the circuit for Chorus works.
What differentiates the two is the switch. (Chorus does not use the variable Depth and Rate)
I would suggest that you check that.
« Last Edit: June 15, 2021, 11:46:22 AM by Jazz P Bass »

gbono

  • Elite
  • ****
  • Posts: 308
  • Chip Points: 9
    • View Profile
Re: Roland Jazz Chorus 50 troubleshooting
« Reply #3 on: July 10, 2021, 07:28:14 PM »
So with distortion knob turned to zero you get distorted output? Do you have a signal generator and/or scope?