Welcome, Guest. Please login or register.

October 23, 2021, 10:52:24 PM

Login with username, password and session length

Recent Posts

 

Author Topic: Danelectro Nifty Fifty distortion and hiss  (Read 2006 times)

Mark N

  • Regular
  • **
  • Posts: 13
  • Chip Points: 0
    • View Profile
Danelectro Nifty Fifty distortion and hiss
« on: September 09, 2021, 11:44:36 PM »
Hi there!

I've had a late 90s Danelectro Nifty Fifty amp which worked for a couple of years and then after it sat for a while it developed an unusable distorted farty sound and a large amount of hiss.

It's got a volume and a gain knob. It sounds decent with the volume up and the gain on 1, but when you raise the gain then the problem begins. I can have the volume on 1 and the gain up midway and it becomes unusable.

It seems like it could be a grounding issue, but nothing looks out of place. The speaker vibrates with the noisy hiss/hum. First I pulled the Filter caps and tested them, then all the electrolytic caps, then the input jack, it also has 2 TL072 IC chips neither gets hot during use.

Anyone have any ideas? Or what I should check next?

***Also: The method I used to check the Electrolytic caps was (1) hooking them up to a multimeter setting it to resistance at 20v  and watching it go from 0 to infinity (actually with my multimeter it starts to rise and then at some point just goes blank) (2) Charging the cap with a battery and then watching it slowly drain using a multimeter (3) Popping it into my breadboard and passing a guitar signal through it to a working amp.

All of them passed #3. With method #2, some held a 9v charge (the filter caps) smaller caps held a smaller charge (which I assume is normal?) and method #1 Filter caps kept going high until the multimeter showed a blank screen. Some smaller caps felt like they blipped out after a small number (but since they did well with tests #1 & 3, I assumed it wasn't too much of a problem)

Enzo

  • Legendary
  • ******
  • Posts: 2042
  • Chip Points: 225
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #1 on: September 10, 2021, 01:44:18 AM »
Well at least you didn't just measure capacitance with your meter.

Problem is with all this low voltage testing is that it doesn't put real world voltages on the cap.  I often put caps on a leakage tester, and they look fine at 20-30-40 volts, but up at 450v where they normally live, they leak like a screen door.  Of course this solid state amp doesn't use high voltage, so that may be moot.

You mention grounding, not sure why.  Grounding usually causes hum problems, same with weak filter caps.

In a small low power solid state amp, hiss to me usually means a semiconductor.   I don't know what is inside these, but likely op amps?  If so, one may be noisy.  I'd look for any DC offset on any IC output pins.

Enzo

  • Legendary
  • ******
  • Posts: 2042
  • Chip Points: 225
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #2 on: September 10, 2021, 02:06:08 AM »
I found a video of a guy making changes in one of these, so I got a good look, it is a basic amp with a five-leg power amp IC and a couple op amp ICs.

Mark N

  • Regular
  • **
  • Posts: 13
  • Chip Points: 0
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #3 on: September 10, 2021, 10:01:15 PM »
Thanks for the reply Enzo and thanks for the interesting info about high voltage conditions. I didn't know about that at all.

I couldn't find a schematic online but IC1 and IC2 are TL072 op amps. There's 2 transistors as well and a five-leg TDA2030A power amp IC connected to a heat sink. I usually work on pedals so I don't come across stuff like this, please forgive/inform me if I'm not using the right term.

Also, I'm unsure of how to check for DC offset on any of IC output pins. I did a quick google and couldn't find anything. What's the best way to do this? A link to an article would be fine, I don't want to take up anyone's time. I greatly appreciate the help.

Enzo

  • Legendary
  • ******
  • Posts: 2042
  • Chip Points: 225
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #4 on: September 11, 2021, 01:05:17 AM »
TL072 is about as common as it gets, dual op amp chip.

So it basically functions but sounds real crappy.

I am guessing the op amps run on plus and minus 15v or possibly 12v.  Pina 4 and 8 of the ICs are the power pins, -15 on 4 and +15 on 8.   Are both present and more or less same voltage?   Pins 1 and 7 are output pins. They OUGHT to sit around zero volts.  If they sit at +15 or even just +2 or something, that is unwanted DC offset.  Offset just means a DC voltage you don't want there.

phatt

  • Legendary
  • ******
  • Posts: 2210
  • Chip Points: 273
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #5 on: September 11, 2021, 09:22:06 AM »
One likely culprit is the TDA2030.
Check if the speaker output has any DC voltage on it, should read very close to zero DC at the speaker terminals. if way off then the power chip is likely blown.
Phil.

Mark N

  • Regular
  • **
  • Posts: 13
  • Chip Points: 0
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #6 on: September 12, 2021, 12:51:02 AM »
Assuming I did this correctly (Set the multimeter to DC Voltage, chose 20 as the value)

 IC1
Pin 1: 0
Pin 4: -10
Pin 7: -9
Pin 8: 9

IC2
Pin 1: 0
Pin 4: -10
Pin 7: 0
Pin 8: 9

Phil: Thanks for the suggestion. I checked got 0 on both speaker connections.

Enzo: By what you said, IC 1, pin 7 is a problem area, correct?
« Last Edit: September 12, 2021, 12:01:11 PM by Mark N »

Enzo

  • Legendary
  • ******
  • Posts: 2042
  • Chip Points: 225
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #7 on: September 12, 2021, 01:59:36 AM »
Yes I would try a new one in that spot.     Having said that I'd also look at the input pins to make sure no DC is sitting there.   Pull the old IC and check the pins 5 and 6 for DC when the IC is out.

Mark N

  • Regular
  • **
  • Posts: 13
  • Chip Points: 0
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #8 on: September 12, 2021, 05:33:47 PM »
Replacing IC1 did the trick. It's up and working and sounds good.

I did measurements and noticed pin 1 has a -1.9 reading. Anything to be concerned about?

On to my next amp to fix!

Enzo

  • Legendary
  • ******
  • Posts: 2042
  • Chip Points: 225
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #9 on: September 13, 2021, 12:25:10 AM »
If it sounds good and the IC is not getting hot or something, call it a day.

Mark N

  • Regular
  • **
  • Posts: 13
  • Chip Points: 0
    • View Profile
Re: Danelectro Nifty Fifty distortion and hiss
« Reply #10 on: September 13, 2021, 02:08:21 AM »
Ha, That's what I was thinking. Thanks Enzo! You saved me some time poking around the components one by one.