Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

May 20, 2024, 04:50:09 AM

Login with username, password and session length

Recent Posts

 

Fender Frontman 15G

Started by Blacklabel, July 22, 2007, 06:39:45 AM

Previous topic - Next topic

Blacklabel

Hi, thanks for the reply, but its not the fuse thats blown...
i was jamming with my Boss Metal zone Mt-2 pedal, running it through my amp listening with the head phones now i cranked the level and the gain/Distortion on the pedal to full, doing some harmonics and stuff while my headphones were set to about 3 on the volume in the amp and after bout 20 seconds of playing my amp just turned its self off, i turned it off and on again but nothing...no led, no volume nothing....its as if its not plugged in to the mains power, even thou it is...i tried my amp in another power point...but still nothing, i pulled the circuit board out and had a look and the fuse seems fine and i cant see anything blown. The Main power LED does not light up at all..Its not blown and neither are the 2 Smaller LEDs in the preamp stage..i think there there to stop from blowing the amp...i have replaced the 2 elec capacitors and the rectifier diodes that are linked to them..and it still wont work..i am now going to replace the 2, 220k 1 watt resistors that are linked to them also and see if that works...any suggestions please post..and i will post pix asap.
thanks

joecool85

Have you checked for voltage anywhere?  It really does sound like a blown fuse.  Sometimes they will look alright but have a crack in the fuse part.  If you have voltage before the fuse and not after it, then you know its the fuse.
Life is what you make it.
Still rockin' the Dean Markley K-20X
thatraymond.com

LJ King

Quote from: Blacklabel on August 09, 2007, 03:21:53 AM
and it still wont work..i am now going to replace the 2, 220k 1 watt resistors that are linked to them also and see if that works...any suggestions please post..thanks

Replacing a 220 ohm 1 watt resistor with a 220K 1 watt resistor isn't going to help much. I hope it was just a typo.

XinTX

Quote from: R.G. on August 09, 2007, 12:27:19 AM

Well, there are several obvious design flaws I see in the schemo.

Such as? 

Blacklabel

#19
Hi guys, i replaced the fuse..and Bingo..i have power..hahahah it didn't look blown..but it was...Thanks Joecool85...any way problems not over it now has a loud buzz sound comming from the speaker when you turn it on....and also when you turn it on the small led called LD1 lights up on the circuit board..no its not the power indicator light..its one inside..i think its a clipping light to stop blowing parts..any one got any ideas on what might be causing it..thanks

teemuk

#20
If it buzzes then usually the first thing to do is to check the condition of filter capacitors (and their solder joints). These are C29, C30, C31 and C32. LD1 is one of the diode clippers for the drive channel - it doesn't stop parts from blowing up, just adds distortion by limiting the signal amplitude by clipping the signal tops off. In this case it clips off the top of the buzz signal.

Blacklabel

hi, thanks for all you help everyone but now its just blowing fuses :'(..so ive given up on it :trouble..ill use the case and pots and speaker for another project...and i suggest every one bypasses the fender frontman series when buying an amp....too much trouble..but i thank every one who has helped me out....

XinTX

Quote from: Blacklabel on August 12, 2007, 05:00:26 AM
hi, thanks for all you help everyone but now its just blowing fuses :'(..so ive given up on it :trouble..ill use the case and pots and speaker for another project...and i suggest every one bypasses the fender frontman series when buying an amp....too much trouble..but i thank every one who has helped me out....

My problem as well.  Just blows fuses.  Mine blows them instantly, so I can't even probe to check voltages in the circuit (the only diagnostic on the schematic).  Agree the Frontman series are total garbage.  I'd also advise folks to avoid them.  And I'm going to use the cab and speaker for my own project. 

R.G.

Quote from: XinTX on August 09, 2007, 01:34:12 PM
Quote from: R.G. on August 09, 2007, 12:27:19 AM
Well, there are several obvious design flaws I see in the schemo.
Such as? 
1. It perpetuates the Fender Mistake of using 15V zeners to power opamps. CR11-12 should be replaced with 7815/7915 regulators and R48-49 lowered to 150R 1W.
2. I can't find any local decoupling for U4
3. No local decoupling for opamps
4. board-mounted pots and jacks

Those are the ones that come to mind immediately.


R.G.

Quote from: Blacklabel on August 12, 2007, 05:00:26 AM
hi, thanks for all you help everyone but now its just blowing fuses :'(..so ive given up on it :trouble..ill use the case and pots and speaker for another project...and i suggest every one bypasses the fender frontman series when buying an amp....too much trouble..but i thank every one who has helped me out....
You got some good advice early on that you haven't taken yet.

You can't debug fuse blowing problems very effectively if you only get 35 milliseconds of test time before the next one blows.
Quote
First: Before you turn the amp ON again build yourself a current limiter out of a light bulb that plugs between the amp and the main receptacle. It will prevent any further destruction.

http://repairfaq.ece.drexel.edu/sam/tvfaq.htm#tvtslbt
http://www.diyguitarist.com/PDF_Files/AmpCurrentLimiter.pdf
Go do it. There's a cleaned-up version of this at GEO (http://www.geofex.com) that is a little safer wiring as well.

But do it. That will let you quit tossing in fresh parts to wherever someone thinks you MIGHT have a problem.

There is a disciplined way to go about this.
1. Get the fuse blowing to stop so you can test voltages.
2. Test the power supply and get it running correctly, not blowing fuses
3. Remove the limiter and test individual pieces.

What you're doing in asking "Anybody know what it might be?" is asking to be told to replace a whole chain of expensive parts in hopes of eventually replacing the one or two failing ones by random luck.

Do the limiter, then get back here and we'll go to the next step. I've helped lots of people get running again with remote debugging. Maybe we can help you too.

Blacklabel

thanks all for your help its ok tha dead amp still doesent work so ill us it for a project later on down the track...im now the prowd owner of a Marshall Valvestate VS100R Combo, so once again thanks for all you help.

BLACKlabel :)

Brian Ward

I know this is an old topic and It's quite possible that someone else has started a new one somewhere. I stumbled onto this one while looking for parts for  one of these Fender Frontman 15G amplifiers. I thought it might be useful for someone else who is having problems with this amplifier blowing fuses.

#1 - Do not defeat the fuse. It is there to protect you, the wiring, and other components in the amplifier. If you defeat it you will be looking for a hard to find transformer that is out of production. 16.4V on the secondary (output to the amplifier)

#2 Replacing random parts is a huge waste of money and time. As someone else has already stated earlier in this thread there is a process for diagnosing repairs. Always check the fuse first. Just because it appears good doesn't mean that it isn't blown. Use a multi-meter and test for continuity.

Okay, now that I got that out of they way. It is helpful to do a little homework before you begin any work for a products known issues. It can save you a lot of time and often someone else has already repaired the item many times and shared their knowledge. I found this to be the case with the Frontman 15G and other similar amplifiers.

Yes, many of you are right in your assumptions that the amplifiers are junk. They are poorly designed and have problems. Let's be honest here. Not too many of you are building amplifiers. It's pretty easy to say it's junk when you've had problems with it, but in honesty it can be a decent little practice amp for a great many people when treated kindly.

The most common failure with the amp is when using the headphone jacks or the external input from another device. The J-fet will fail and can often damage some parts around it. These are fairly cheap to buy by most standards and are easy to replace. Adding an external heat sink above and beyond the one Fender supplied with the amp can also extend this transistors life a great deal. Keeping the drive moderate (This includes using pedals at a reasonable level) will also go a long way to keep it running.

Who doesn't like distortion? I know it's all part of the fun and often part of the sound. Distortion damages speakers quicker than anything else. Keep this in mind when you've got it squealing and howling.

So, let's begin diagnosis. You should have already checked the fuse. If the fuse tests good you're headed in the right direction. If it doesn't replace it and sometimes you get lucky and you're back in business.

Fuse blows immediately? Well, that means you need to find out what is causing an overload condition. Something is drawing too much power (Likely that main power transistor / JFET that Fender put into the amplifier.  Replacing the fuse again at this point is a waste of time. Meter the secondary on the main power transformer and see what the voltage is.

The Fender Frontman 15G should be between 12 - 18 volts. The transformer I have is rated at 16.4V. If you've got some voltage that's larger or smaller your amp likely won't work. You're going to be searching for that transformer for a while.

Transformer seems okay? Check the input voltage at the JFET and also the output voltages. Nothing huh? Replace the JFET it's a TDA2030 for the 15w or a TDA2050 for the 30w version. Replace it with one that matches your model.

Likely this will have your amp up and running.

As for buzzing in the amplifier. This is usually a grounding issue on the signal path. it can also be caused by poorly done solder work. Make sure that when you solder things that you use a heat sink and do not make cold solders. Check that there is no solder paths being made where you don't want them and always check your work before you apply any power.

Katoda

Most likely the TDA2030 burnt out. I had the same problem, instead of replacing the chip, I took all the guts out and built in some valve stuff  8)

J M Fahey

Weird post with a few inaccuracies strong enough to merit correction:

Quote from: Brian Ward on January 28, 2016, 05:16:20 PM
QuoteYes, many of you are right in your assumptions that the amplifiers are junk. They are poorly designed and have problems. Let's be honest here.
You did not read that in this Forum .
QuoteNot too many of you are building amplifiers.
Again you refer to some other Forum.
Quote
It's pretty easy to say it's junk when you've had problems with it,
Again .....
Quote
The J-fet will fail and can often damage some parts around it.
Which J-Fet ?
Quotecan also extend this transistors life a great deal.
Which transistors?
Quotethat main power transistor / JFET that Fender put into the amplifier. 
Which transistor/JFET?
QuoteReplacing the fuse again at this point is a waste of time. Meter the secondary on the main power transformer and see what the voltage is.
Well, this one is easy: 0 Volts.
What you will always measure if you don't replace the fuse.
QuoteCheck the input voltage at the JFET and also the output voltages. Nothing huh?
No input voltage: means amp OFF (or lack of fuse or fuse blown open).
No output voltage: means nothing if it's not receiving any power to begin with.
Anyway your test might be approppriate for a 3 leg Voltage Regulator.
Since we have a 5 pin power amp I'm not sure about the test as described.
Quote
Replace the JFET it's a TDA2030 for the 15w or a TDA2050 for the 30w version.
Oh, those, you mean the chipamps?