Welcome, Guest. Please login or register.

December 06, 2021, 12:12:59 AM

Login with username, password and session length

Recent Posts

 

Author Topic: Marshall 5010 30 watt Master Lead Combo  (Read 8395 times)

memoryman

  • Guest
Marshall 5010 30 watt Master Lead Combo
« on: March 24, 2013, 01:09:52 AM »
Great amp with a small problem...when the preamp gain is turned all the way up there is a squeal(even at low volume). I replaced the filter capacitors, preamp pot, and both Carlington power transistors. I also made sure the solder connections were good on all the pots. The amp sounds better but it still squeals, what next?
« Last Edit: March 24, 2013, 01:33:20 AM by memoryman »

Roly

  • Legendary
  • ******
  • Posts: 2184
  • Chip Points: 289
    • View Profile
    • Australian Valve Amps
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #1 on: March 24, 2013, 01:57:25 AM »
Does this do it all the time, or does plugging in an input lead/guitar/stomp change what happens?

{prob'ly a typo, but they are Darlington transistors, and pretty unlikely to be the cause of your problem.}
If you say theory and practice don't agree you haven't applied enough theory.

memoryman

  • Guest
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #2 on: March 24, 2013, 06:26:18 PM »
I have tried several guitars and cords with the same results and it is consistent.Thanks for the reply.

Roly

  • Legendary
  • ******
  • Posts: 2184
  • Chip Points: 289
    • View Profile
    • Australian Valve Amps
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #3 on: March 24, 2013, 10:11:04 PM »
What I had in mind was the shorting contact on the input socket.  If this gets dirty and doesn't close properly then the input is left open circuit to pick up feedback from later in the preamp.

Since you have renewed all the power supply bypass caps I would then be suspecting a dry solder joint somewhere, near the front end and on the ground side I would suspect.  If the input socket mounts directly onto the printed circuit board have a very close look at its solder connections, they get a hard time with this style of mounting.

HTH
If you say theory and practice don't agree you haven't applied enough theory.

memoryman

  • Guest
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #4 on: April 02, 2013, 03:42:09 AM »
You nailed it the "high" side jack was shot. I replaced the plastic "Cliff" jack with a new one and it works fine.Thank you for your suggestion.

Roly

  • Legendary
  • ******
  • Posts: 2184
  • Chip Points: 289
    • View Profile
    • Australian Valve Amps
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #5 on: April 02, 2013, 05:01:01 AM »
Good to hear.   :dbtu:

Despite the fact that modern amps tend to have a bucketload of front end gain this really shouldn't happen and suggests poor circuit layout internally.
If you say theory and practice don't agree you haven't applied enough theory.

solidstate2199

  • Regular
  • **
  • Posts: 24
  • Chip Points: 1
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #6 on: December 01, 2016, 02:07:07 PM »
I have to dig out this thread because i recently acquired a 5010 Combo and
i have exactly the same symptoms.

I thought it had loose caps or otherwise loose stuff in it but nada.
So bassically only if i plug any guitar into the "High Input" and turn up the
preamp gain to 9 to 10, so full on distortion, it starts the squeals.
These squeals change pitch and intensity if i change volume and tone on guitar.

But here is the thing why i dont suspect the input jack, first i put a distortion box
between my guitar and amp- the squeal goes away - any distortion box or even a buffer pedal.

If i take a 8 foot long cable - the squeal goes away!

But am not happy with it because i can feel that with the shorter cables and direct in the amp is way
more brighter and more aggressive which i like...so bassically high frequencys get lost with long cable or any
stomp between it.

Can it still be the Input "Cliff" Jack, or a broken solder joint on that jack?
I have one here so i could change it right away...coulkd it be the jack or does the long cable proofes
different?

Like always,
thanks for the help guys!

( I already cleaned all the Jacks with good contactspray and tapped all components
with a wooden chopstick while running the amp in "squeal" mode, no reaction so
i guess either component values have driftet significantly or the damn cliff jack is the
reason. i read these jacks have some type of overcoating which is bassically part of the
signal-way, so if the coating goes, the signal is affected...its still weird because longer cable
or stompboxes stop the squealies! but my amp makes exactly what the other guys amp does, i hope its just the jack.I really start to think about not buying over internet anymore, i mean only pickup and test before buy!
« Last Edit: December 01, 2016, 08:48:53 PM by solidstate2199 »

Enzo

  • Legendary
  • ******
  • Posts: 2056
  • Chip Points: 233
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #7 on: December 01, 2016, 04:01:30 PM »
So the controls on the guitar affect the squeal?  Does it matter if you turn your body holding the guitar?  In other words, does "aiming" the guitar different directions change the tone of the squeal?

This thread is about a 2199 amp, but you have a 5010.  Without me looking it up, are they the same circuit?

If you amp has op amps inside, they are probably supposed to be 1458 type.  if you find other newer types in there, that could be it.  newer op amps are unstable in old Marshall SS amps.

solidstate2199

  • Regular
  • **
  • Posts: 24
  • Chip Points: 1
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #8 on: December 01, 2016, 04:07:06 PM »
Hi Enzo,
please dont get this thread confused with my other thread about the 2199 amp.
This is about a 5010 which has exactly the same symptom as the one that user
memoryman had. amp is a 5010.

no the squeal dont change with moving. its an electronic feedback squealing not acoustic.
thanks.

i guess i just have to bite the bullet and change the jack right away.
im just interested why the squeals goes away with changing to a longer cable
or putting a stompbox between, i guess it has something to do with impedance.

inside the amp looks all original to me no-one in there before.
man and i hoped to just play the damn thing...well out comes the soldering iron ???

no not the same circuit at all, the 5010 is the 2nd generation master lead 30w, 2199 1st generation. circuits are similar though- sound of 5010 is lightyears ahead!
more clarity, more bass, no mud att all like 2199s.
But the 2199 is very good for non-distorted to crunchy 60s music, distortion is a "bad!" joke on 2199. the 2199 distortion is like "real distortion" it gets bad pretty quickly.
i hope i can mod 2 of my 2199 amps to 5010 specs, the boards look very similar infact, i think its possible.
cheers
« Last Edit: December 01, 2016, 04:17:30 PM by solidstate2199 »

Enzo

  • Legendary
  • ******
  • Posts: 2056
  • Chip Points: 233
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #9 on: December 01, 2016, 06:32:25 PM »
You are right, I confused the threads.  Hey, I am old...

The reason I suspected pickups is the longer cord has a higher capacitance, which would damp oscillation better.  In high gain circuits, pickups can feed back even at low volumes.  If the input of the amp is overly sensitive, putting a pedal there removes the guitar from the input.  Even having the shielded cover off the pickup hatch on the guitar can matter.

If I remember, the 2199 was all transistor, while the 5010 has an op amp in the front.  it may look original, but just to humor me, make sure it is a 1458 instead of 4558 or other type.  I stock 1458s solely to put into Marshall amps of this era to cure instability.

Conversion?  You will have to deal with powering an IC, which expects a split supply or using it offset.   Otherwise a great deal of similarity does exist.

solidstate2199

  • Regular
  • **
  • Posts: 24
  • Chip Points: 1
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #10 on: December 01, 2016, 09:23:21 PM »
I am pretty sure its a bad solder joint on the "High Input" Jack
or its somehow defectice, dirty i think not i used good contactspray on it
which otherways always worked if something was slightly corroded.

Here i found another thread  whith a similar Marshall with exact same symptoms.
So 2 times it was the jack, it points in this direction.
Ill give it a close eying these days and try resoldering first and then replacing.

This is probably very common on the 80s Marshall Solid State Amps.


Thread Marshall 5210 squeal question

Code: [Select]
talk about a wild goose chase!!
The switchcraft input jack was it!
The  board wasn't grounding properly on it's mounting post and the amp was grounding the chassis through the input jack causing a ground loop.
It sounds far fetched, but i could duplicate and repeat this condition.
I'm going to order the correct jack.

« Last Edit: December 01, 2016, 09:25:22 PM by solidstate2199 »

Enzo

  • Legendary
  • ******
  • Posts: 2056
  • Chip Points: 233
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #11 on: December 02, 2016, 01:03:13 AM »
So solder it and find out.  That is more effective than thought experiments we can perform here.

g1

  • Legendary
  • ******
  • Posts: 718
  • Chip Points: 89
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #12 on: December 02, 2016, 03:00:20 PM »
Check that board mounting ground screw that was mentioned in the thread you quoted.  It sounds like that is what cured his problem, not the jack?

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Posts: 4142
  • Chip Points: 429
    • View Profile
Re: Marshall 5010 30 watt Master Lead Combo
« Reply #13 on: December 04, 2016, 05:04:45 PM »
Threads are in the Ether Space and that amp is on your bench, just replace the d*mned jack ;)

As of:
Quote
im just interested why the squeals goes away with changing to a longer cable
or putting a stompbox between, i guess it has something to do with impedance.
yes, wiring between jack and first transistor base or Op Amp input pin, both sensitive and high impedance spots, acts like an antenna an catch its own output: feedback.
Lowering impedance (pedal) or setting guitar volume to 0 pr putting some capacitance across it attenutes highs enough.
Personally I always solder a 470pF cap across my amps input jack , experimental value "as high as I can get away with without killing highs".
Works very well, try it.

Some get angry at me because of that "kludge" , but considering guitar cables are around 100pF per meter, 5 meters of very good cables or 3 m of cheesy one are already that and nobody complains, so ...