Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Psabin8951

Pages: [1]
1
Tubes and Hybrids / Vox vt120+ combo schematic needed
« on: September 29, 2020, 12:17:14 PM »
Does anyone have a schematic for a vox vt120+ valvetronic combo please.
Or even be able to tell me values for C184 and C185 as both are burnt out erasing markings.
Many thanks

2
Tubes and Hybrids / Blackstar HT5 noisy Clean channel
« on: August 15, 2020, 09:51:48 AM »
I have an early (non reverb) Blackstar HT5 here which has a noisy clean channel which occasionally has volume drop but mainly has a crackle and hiss that appears after about 10 mins of being on.
Both valves have been replaced with new matched ones and all connections have been cleaned, checked and resoldered to eliminate them.
Any thoughts what it could be?
At initial switch on it sounds great.

3
Tubes and Hybrids / JTM60 Combo rectified diodes fried
« on: November 05, 2019, 04:15:27 PM »
I have just been given a JTM60 combo.
Its HT rectified diodes D105,106,107,108 are all blown (literally!).
Obviously I can replace these but what would have caused this?

4
Tubes and Hybrids / ENGL Fireball E625 Head white noise issue
« on: May 31, 2019, 03:07:20 AM »
A friend has just got hold of an ENGL Fireball E625 60 watt amp head. Looks in good condition and works but...
When ultra gain switch is turned on there is a large amount of white noise with the guitar sound.
If the guitar is plugged into the effects return and level set to full effect then there is no noise just pure guitar.
Any thoughts on the cause? The seller told him it has had new valves but obviously that's not gospel!

5
Tubes and Hybrids / Marshall 8080 combo blowing fuse and more
« on: April 11, 2018, 09:36:42 AM »
I have a poorly Marshall 808 combo come my way.
It was blowing the internal fuse when received and by isolating the circuit I know the +15v and -15v areas of the circuit are ok as is the tube heater portion which leaves the power amp stage. With R84, 85 and TR8 removed from the circuit it powers up fine.
With R84 reintroduced again it powers up fine.
With R85 added too, that resistor severly overheats but doesnt blow fuse.
If TR9 is out of circuit R85 doesnt overheat.
With R85 back out and TR8 refitted the fuse blows.
Can anyone point me to what is likely to be the cause?
I have attached a pic of the circuit in question

6
I've just had a Blackstar Series One 45 Combo come to me with no output.
Upon inspection there are two resistors totally burnt out - R3 on the EL34 power tube board and R6 on the ECC83 board.
Does anyone know the values of these components and or have a schematic please?

7
Amplifier Discussion / Vintage Roland Cube-60 Reverb
« on: September 12, 2017, 02:27:58 AM »
I have an old cream coloured Roland Cube-60 which came to me with reverb issues.
Initially it had no drive going to the spring tank input, that was due to a pin sheared at pcb level on the driver ic. With that sorted there is sound going in but nothing coming out unless you twang the springs. So I'm guessing a new tank is the best bet but does anyone know what spec I need ie input/output impedance and delay length?
Thanks

8
Hi all,
I have a Hartke A25 Bass combo that has stopped working.
Having checked the usual fuses etc (which were ok) I find that Q8 (output stage?) is a charred mess.
So firstly as type number is burnt off, does anyone know what type Q8 is so I can replace it and secondly what would the likely cause be for it to go in the first place?
Any help or even a schematic would be greatly appreciated.
Thanks in advance.

Pages: [1]