Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

April 19, 2024, 07:16:06 AM

Login with username, password and session length

Recent Posts

 

Odd 80s Amp Combo - "Starmaker" any info?

Started by Maddus, December 28, 2023, 03:36:35 PM

Previous topic - Next topic

Maddus

#15
Hi Phil,
here are the photos that helped me. The photo from the solder side is already mirrored to allign with the top side.
I also traced it node by node, so I can't imagine I got something wrong.
I think everything is recognizable on the pictures, the transistors with the flat side facing the output transistors are BC212, the ones facing to the rectifier BC182. Under the dual gang pot sits a 4k7 Ohm resistor (R34).

dmeek

Here is what I get with my pencil-and-paper style

You cannot view this attachment.

Maddus

#17
Anyway, so do I have to make the 100k resistor at the positive input of the first opamp against 12V smaller? Doesn't it have to be half the value of the 12V midpoint resistors? So in my case 5k Ohms?

g1

Where did that example come from?  Why did they say the biasing resistors should equal R1?
The ratios are about RF and Rin and set the gain of the non-inverting op amp.  Your circuit and the example circuits have different gain so the "=1/2 R1" does not apply.

dmeek

#19
The 100K resistor along with the resistor from the input jack sets the input impedance.
If anything I might make it larger like 220K or 330K. It does not change the gain.
Gain of the first stage is set by the feedback resistor divided by the resistor from
the - input to common.
In this case common is the +12V. The gain of the first stage is 1+47K/2.2K = 22.4
You could change the 100K to 1M but you would want a FET op-amp  like TL071 for the first stage

Maddus

#20
Ok so my options to avoid the (asymmetric) clipping in the input stage are:
1. lower the gain, e.g. with 5.6k in place of the 2.2k resistor
2. lower the series 820R resistor further to get over 24V for the IC supply (now 22V) so the 24V zener diode also finally gets involved.
3. Make the bias resistor pair uneven in value, so that I get a bit a higher than 12V, so that when it clips, it clips to the positive rail instead to cutoff?

If I understood the NE5534 datasheet correctly, the maximum output p-p voltage I can achieve is around 5V lower than the supply. And 0.7V input with a gain of 22.4 is already giving 15.4V just by calculation.

g1

Have you verified that the input stage is the first thing that clips before the amp gets to full power?  Seems odd that they would have such little headroom at that stage.
At full power (just before clipping) into a load, what is the peak to peak voltage coming out of the first IC ?

Maddus

#22
Hi g1,
I scoped the first 5 graphs with a signal generator on the normal input. The blue wave is from in front of the 68k input resistor, like directly at the hot tip of the plug (the voltage at pin 3 is then about half of that value, e.g 700mV in the first image). The yellow is at pin 6 (output) of the first opamp. In the bottom bar you see the Vpp values, at 16V it is beginning to flatten on the negative side.
The riff.jpg is the "smells like teen spirit" riff played with a Les Paul on the bridge Burstbucker 2. There you can see, that I get easily peak voltages that would cause clipping.

Tassieviking

#23
To get asymmetric clipping like that makes me wonder if the input to the OP-Amp is biased at 1/2 voltage.
Can you measure the voltage across pin 4 to 3 on IC1, also across pin 4 to 7 and pin 3-7, all with no guitar plugged in.
If it is not set at 1/2 you might be able to tweak the value of R16 and R17 until you get exactly 1/2v at the input at pin 3 on IC1.
You might even have to change the bias slightly off to make IC1 clip evenly.

This is just my thinking and i could be wrong, I think the bias on the input to the OP-Amp determines how the output hits the power rails and flattens out.


If you have a spare 20k pot (or bigger) then connect it to 0v-22v and lift the leg on R20 that goes to the +11v and connect it to the viper on the pot, then you can adjust the bias voltage you have created to see what happens to the clipping on the input stage. (If you can understand my crazy way of explaining it)

Rail to rail clipping is used to produce distortion in some amps just like people use diodes or leds to clip the waveform to produce distortion, it might have been intentional on the amp just to make the sound you don't like but the designer wanted.

EDIT: I did a quick trace of the preamp to see what I got, I used the values already quoted and also the references.(I haven't double checked it or anything)
It looks like a basic baxandall tone stack for Bass & Treble and then the Mid is just like the active Mid in a Lab Series L4 Bass Amp.


Cheers
Mick
There are no stupid questions.
There are only stupid mistakes.

g1

I think if you tweak it to get symmetrical you will still overdrive the stage anyway.  And it won't sound any better if it's clipping evenly on both sides rather than just one.  It's not really meant for that kind of guitar signal.
Some tubes amp do that as well, the gain stage before the volume control clips unless you turn down the guitar volume.  Just that with tubes no one really minds as much because the clipping is softer.

You can tweak the gain of the stage to deal with it, but you might just find the next stage or somewhere down the line clips the same way.

That's why I suggested getting full unclipped output and seeing what kind of input signal level that requires.

Maddus

Thanks for the suggestions, guys.
I don't think that clipping was considered by the designer, because it sounds like someone is lifting the needle off a vinyl record too roughly - like "pbbfffzzttt"  ;D .
Last night I simulated the first stage in LtSpice, and the clipping behavior was exactly the same to my measurements.
I played with the values and tried to stick to the scheme in Figure 2 of this:
https://www.analog.com/en/resources/analog-dialogue/articles/avoiding-op-amp-instability-problems.html
But when I use 100k/100k bias resistors in reality, then my 12V ref descends to about 9V. So I got back to 10k/10k, that gave me 11.8V. I also lowered the 820R in the supply to 680R, so I have now real 24V instead of 22V. The gain was also lowered to 19; the screenshot shows the final values I soldered in.
On the o-scope it looks very good now, should be enough headroom. Tomorrow I will test it with guitar and speaker.

I guess what this modding is making so difficult is that the amp was designed for the CA741's and the change to NE5534 brought higher bias and supply currents.
Like someone already wrote, perhaps I should have chosen the TL071.

Maddus

Tested it, and I still got occasional pops on powerchords  >:( .
Now I'm fed up with varying resistor values, I just built a diode limiter and put it at the input before the coupling cap. Now it is rock solid, finally I can windmill my Les Paul and get no unpleasant cracks or pops! I used a 22k pot to make clippig asymmetric on demand, but the effect is more subtle.
Main thing is, that this is now a very good portable pedalboard amp. With that para mids you can dial in any flavour of distortion with just one dirt box in front.