Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - DrGonz78

#556
Amplifier Discussion / Re: Randall RG80/100ES QUESTION
October 02, 2012, 05:13:08 AM
Sorry Juan I was just having fun... I was goofing off and not being as serious as I should have been...

I miss details of a post every time either way and I find that my newbish ways are tell tale signs that my advice is not as good as it could be. I will try better in all my posts forward and not just be a goof.

#558
Okay I see... Yeah I am learning as well as we all go here too!! lol  :duh But I was imagining other type of thermistors than this one. Larger one's located near the fuse and transformer input stages on the board. Maybe I am even thinking of a different Fender FM65, princeton212 or something like the RocPro??? Props to Roly for his greater experience than mine.  :dbtu: Sorry I even had the wrong idea going on the output transistors for this amp...

Yeah if all the soldering looks nice and shiny that is good to know about the condition of the amp. If you flow solder on at least the components like wire wound resistors and filter caps that might be just enough. I like to practice soldering a whole board at a time as I am new at this and it helps to practice.

This might not fix anything yet, but now you will know the condition of the board as a whole. Also, this will get you really familiar with the entire amp. Be careful and take some care putting it back together. Remember to clean off the heat sink and apply new thermal grease when you put the board back together.
#559
The thermistors are there at the entrance of power stage and they are resistors that change their resistance in response to the amp heating up. This is different than the output transistors tip142 & tip147 that are mounted to a heat sink w/ the thermal compound coupling the connection between the two. Now those transistors I can imagine a white substance, but have only seen glue holding thermistors tightly to the PCB board.

So I have worked on a few of these 1999 boards and that would indicate to me that it is made in Mexico rather than China. My best recommendation is to fully solder up that board and make sure every connection is connected to the board nice. As you take off the board you will need to make sure that you document where each connection belongs. Take a sharpie and write J9 or J11 on the plastic part. When you get to putting it all back together you will need thermal grease on the heat sink and make sure the heat sink bar is on the right way. Take a sharpie and write an arrow pointing up to ensure this is correctly put back together. This amp probably just needing some solder, but then after you do all this play the amp and see if there is any noticeable changes. At that point this only can be good for the amp if you are handy w/ a solder iron...

If the amp is still acting up then we can start looking into troubleshooting.

#560
A thermistor covered in a white substance??? I want to see this... Take pics for me and all to see.

Or it's just the glue they put in there to hold in place just in case? This sounds strange.