Welcome to Solid State Guitar Amp Forum | DIY Guitar Amplifiers. Please login or sign up.

October 07, 2022, 01:38:23 AM

Login with username, password and session length

Recent Posts


Blackstar ID Core 40 'Bricked' Problem

Started by Clyde, July 20, 2016, 05:14:59 PM

Previous topic - Next topic


I'm looking at a Blackstar ID Core 40 that will not power up.  It uses an external laptop type power supply & it's putting out 16vdc to the PCB.  I do not have a schematic for this unit and doubt I'll ever see one given Blackstar's policies.  So I'm pulling data sheers for the various IC's & checking voltages.  Eyeballing the board reveals no obvious issue.

But...I'm reading that a few other folks have experienced dead/brick problems with this line after performing firmware updates via the 'Insider' software app that Blackstar has.  It allows access to patches & a bunch of features but also checks for & installs firmware releases.  Like other firmware updates, if they do not go in perfectly they can cause a total lack of communication & indications just like no power.

Has anyone had any experience with this firmware issue?  The microcontroller on this is a LPC4330FET180...180 ball array that I am not even close to being at home with.  Should I consider this a 'brick' and sell it as wall art or is there a path to repair?  Past experience with the USA distributor and parts supplier tells me that a replacement PCB would be difficult to obtain as well as costly. 

Just looking for thoughts and direction.  This project has me in the deep end of the pool.


The more I look into this problem the more I believe that this is data corruption from a bad upgrade.  No lights, no boot, no visual anything.  Yet I can read power at the PCB & at all of the IC's (16vdc, 3.6vdc, etc). 

I'm going with trying to use a basic chip programmer (ala Arduino/Serprog) and trying to 'flash' the M25P16 serial memory chip.  Problem here is I believe I need a binary file from a working amp to write to the non working unit and I don't know where to get that from (other than from another amp). 

Any suggestions?



Bad software doesn't kill power supplys. Not even Microsoft.


Firmware and related issues can make it seem like it is not powered, but so can many other problems in a circuit.  Don;t assume.  You may have power, but is there clock in the system?  Without a diagram, it will be difficult to identify the power up reset circuit, but if you have identified the processor IC, you ought to be able to find its reset pins and see if they are being held.

How old is this amp, are you the original owner?  Any chance it is still under warranty?


I'm not the original owner of this amp.  I recently picked it up for $30 USD from a seller who had no info other than it didn't power up.  According to my breakdown of the serial# it is of 2014 vintage.  No chance of warranty.

Of course I was hoping that his would be a power brick or fuse/open/short issue.  Not.  Input voltages at the various IC's read within tolerance per the datasheets...but w/o a schematic I am guessing.  But distribution is there.

The NXP LPC4330FET180...I've pulled a datasheet for that but it's a block of a ball array that sits atop the PCB with no way to discern what leads  go where.  Still looking at that.  I've yet to check for clocking.  I'll do that next.

I didn't believe that firmware issues could cause these symptoms, but researching common problems with these amps I found a number of complaints about identical symptoms caused by upgrades gone bad.  Peavey Vypyr too has had problems akin tho this as identified and corrected in This YouTube vid  All things being equal, I felt that this problem was inherent to the breed enough to where I took the firmware route as a path of least resistance approach.  Not the best troubleshooting approach but I'm flying a bit blind here.  I figured this was going to be a learning experience.  Not disappointed.  More like PC repair than I'm used to (see: hobbyist).

Thanks for the response guys.



Have we explored a reinit?  Blackstar may not pass out schematics, but they may have a "restore factory settings" memory reset available to the customers.  All that means is a reinitialization, which could possible help and couldn't hurt.


I've followed Blackstar 'Factory Reset' (restore fact settings) by depressing Mod, Dly & Rev buttons simultaneously & turning pwr on.  No response.  Also tried depressing Manual & Mod buttons & powering up, which is supposed to force into update mode.  Again, no joy.  I tried all other combinations with the same result.

Checked the 12MHz oscillator after blowing dust out of my Tek 2235.  All there/all good.  I'm currently perusing the 159 pages of LPC4330 MCU datasheet & scanning the 1400+ pages of its users guide. 



I appreciate the suggestions.  It's all worth a shot.  Thanks much.  I'll get back to poking around on this amp later today.


Ask Blackstar if they have a old/previous revision of their "upgraded" firmware. 


I don't know much about these things,, but I did read that you have the amp in the right mode before you flash the chip otherwise a dead amp will result.
I'd be asking Black star for advice.

I just don't go for the idea of an *All in one* rig like this as it's asking for trouble. :trouble
These things will be land fill in a few years,, meanwhile simple straight forward analog amps will run for years.
If you must have all the digital BS buy a Pod or similar. :-X
If they Brick then you still have an amplifier. 8|


I've sent queries off to Blackstar regarding the problem.  Waiting for a response with less than great expectations. 

They had a repository of past firmware upgrade revisions but those files seem to have been removed from their site.  I still may seek out a user of a working amp that can get me a copy of the serial chip data & try to flash this dead one.

If this project stays bricked, it becomes a boat anchor.  For now it's still a good exercise for my gray matter.  It's a puzzle, a challenge, a chance to save something from the landfill and a cheap course.  These types of amps are not my idea of keepers.  If I want digital that requires a PC I use Kazrog, SGear or POD.  And the ss or tube amps that I do have are all old, simple & will last longer than I will.  And I agree about the 'all in one' stuff.  Apparently this is a good example.


Queries sent to Blackstar support remain unanswered.  I thought posting this problem on the Blackstar Forum might help.  Can't get a response from the forum admins to approve joining said forum.  Sent a query off to Korg parts supplier for Blackstar USA, seeking info.  No response.  Interesting, albeit frustrating. 

Any hope of getting a firmware ROM copy is fading completely.  Sure not going to buy a working one just to read the ROM.

Still plugging on this.  And the beat goes on...


Still in-search-of a Flashrom binary read of the data on the IC#2, M25P15 Serial chip from a working amp.  I know it's out there somewhere.  Same story:   the more I probe around on this board, the more convinced that flashing this sucker will give it a spark of life.  PWC does have JTAG connector points but I have yet to venture there.

Blackstar only has a few older firmware releases and they are only available in .exe format on their server thru their Insider app.  No binary file. 

I called Korg USA about this problem & even the possibility of a replacement pwc.  No replacement parts at all available for ID Core 40.  So this is truly a do-not-repair $200 item.  Sad to me. 


Well you convinced me to never buy one. :tu:
sometimes you have to know when to quit. 8)