Solid State Guitar Amp Forum | DIY Guitar Amplifiers

Please login or register.

Login with username, password and session length
Advanced search  

News:

collapse
Pages: [1]   Go Down

Author Topic: Peavey XXL squeal on Ultra channel  (Read 1823 times)

markorock37

  • Master SSGuitarist
  • ****
  • Chip Points: 1
  • Posts: 68
    • View Profile
Peavey XXL squeal on Ultra channel
« on: October 24, 2013, 12:49:32 PM »

I have a Peavey XXL (solid state) amp on the bench. Sounds great until you flip it to the Ultra channel then its squeal mania. It happens across all volume, gain, and eq levels and with different guitars, cables , etc. The issue is in the amp, in the Ultra channel only. The squeal goes away when your actually playing but as soon as you stop its there piercing your ears. Where should I start? I plan on getting it hooked up to my oscope today to see if I can see it.
Logged

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Chip Points: 357
  • Posts: 3273
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #1 on: October 25, 2013, 12:56:35 AM »

What happens if you insert a shorted plug in the input?
Logged

Roly

  • Legendary
  • ******
  • Chip Points: 234
  • Posts: 1686
    • View Profile
    • Australian Valve Amps
Re: Peavey XXL squeal on Ultra channel
« Reply #2 on: October 25, 2013, 05:12:50 AM »

Snooping around it appears that these Peavy XXL's have a bit of a habit of developing microphonics of some sort when they get a bit older (but no indications as to why).

While this is quite common in valve/tube amps it's pretty rare in solid state ones, so there are all sorts of odd things it could be, however I'd first be looking for a dirty contact, and prime candidates would be the switching contacts in the sockets, particularly the good ol' Fx send and Return.  So (after trying JM's suggestion above) try plugging a known good lead into Fx Send and Return and see if that makes any difference, and report your findings.
Logged
If you say theory and practice don't agree you haven't applied enough theory.

markorock37

  • Master SSGuitarist
  • ****
  • Chip Points: 1
  • Posts: 68
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #3 on: October 26, 2013, 11:33:10 PM »

With a shorted plug inserted it the same high frequency squeal. Only does it with the voicing switch set to high gain. I went through and cleaned all the jacks, and all connections inside are solid. No obvious component failure. I cleaned all the ultra channel pots. Testing afterward the ultra channel is no longer squeling. But when I turn the LEAD channel gain to 10 - while on the ultra channel there it is squeel. I'm going to clean that pot and see if it makes a difference. Also no difference with effects loop jumpered.
Logged

phatt

  • Legendary
  • ******
  • Chip Points: 113
  • Posts: 1186
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #4 on: October 28, 2013, 02:47:09 AM »

But who uses amps with all gain turned up max? :lmao:

Maybe you expect too much from the equipment as few professionals use amps in that manner. :-X

I think you will find at 10 you are way past the sweet spot.
Just a thought?
Phil.
Logged

J M Fahey

  • SSGuitar Global Mod
  • Legendary
  • ****
  • Chip Points: 357
  • Posts: 3273
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #5 on: October 28, 2013, 07:19:33 AM »

Short input, raise volume until squealing, lower it just enough to stop, and tap the front panel, the chassis, different points in the PCB with a plastic Bic pen or similar, I suspect a microphonic component.

If none found, then it's a grounding/design problem, way beyond what you can realistically repair, since it involves redesigning.
If Peavey themselves didn't solve it, we mere mortals can even less.
Learn to live with a little less gain in your Life :(
Logged

Roly

  • Legendary
  • ******
  • Chip Points: 234
  • Posts: 1686
    • View Profile
    • Australian Valve Amps
Re: Peavey XXL squeal on Ultra channel
« Reply #6 on: October 28, 2013, 03:40:05 PM »

It seems that this problem only appears after a few years, so I doubt that it's just a design issue.  Like you, I think something is going microphonic, and from @markorock37's comments it could be related to a pot.  Gotta be something mechanical I think.
Logged
If you say theory and practice don't agree you haven't applied enough theory.

Enzo

  • Legendary
  • ******
  • Chip Points: 117
  • Posts: 927
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #7 on: October 28, 2013, 10:15:45 PM »

That is easy to determine.  Play the amp into a load and scope the output.  Is the oscillation still there?  If so, it isn't microphonics.   If it only happens with a speaker, then maybe so.   We now move the speaker into the other room where we can still hear it but it cannot put much acoustic energy into the chassis.

I am always suspicious when I hear things like THIS model develops such a symtpom.   These amps are designed in the same way, by the same people as a ton of other Peavey amps.  They are made on the same production lines from the same  parts as many other models.   There is nothing unique about this amp.
Logged

Roly

  • Legendary
  • ******
  • Chip Points: 234
  • Posts: 1686
    • View Profile
    • Australian Valve Amps
Re: Peavey XXL squeal on Ultra channel
« Reply #8 on: October 29, 2013, 01:27:52 PM »

I'm only reporting what I found by Googling Peavy XXL, several reports of apparent microphonics after a few years operation.  Sure Peavy have a name, but so does Marshall, and no manufacturer is immune from producing a dog, e.g. <http://www.lynx.net/~jc/TSL122.html>.  The Fender Frontman 65 output stage doesn't seem too flash either from what I've been reading.  The Vox AC30 has a well deserved reputation for being hard on output bottles.

Sperry produced a range of neon displays that went spotty after a couple of years because, unknown to them at the time, their production line had been contaminated.  Fairchild had a similar problem with a line of Nixie drivers; even great companies have bad luck.  It could be that one of Peaveys component suppliers was having a bad hair day.

It (and others of the same model) is clearly oscillating for some reason, and be it mechanical or electronic it seems to be a problem that takes time to appear, years, and pot cleaning seems to have at least changed the fault, suggesting it may be mechanical.

Quote from: markorock37
I cleaned all the ultra channel pots. Testing afterward the ultra channel is no longer squeling.


It could also still be something electronic, say related to a bypass cap drying out combined with "Ultra" gain being a step too far which makes the amp sensitive to component aging, but whatever, this is not the only one of this model with this problem.

Your test idea of removing the amp from mechanical stimulus is excellent, but whatever the cause we can bet that, unlike the Marshall, they didn't come out of the factory like this.

I'm a bit dubious that the problem is actually in the Ultra channel; the extra gain may only be exposing the fault.
Logged
If you say theory and practice don't agree you haven't applied enough theory.

Enzo

  • Legendary
  • ******
  • Chip Points: 117
  • Posts: 927
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #9 on: October 29, 2013, 07:32:39 PM »

But you make my point.  If Sperry made displays that failed after a time, then everything that used that display would start having the symptom, not ONLY one model of one brand.

My point was not that Peavey has a name, it was that Peavey made MANY amps in that era, all made on the same lines with VERY similar circuits and designed by the same team.  SO I am leery of ONE model suffering this odd microphonics while all their others do not.

In other words, in my opinion, the amp may well be microphonic, I just don;t think it is because it is an XXL.
Logged

markorock37

  • Master SSGuitarist
  • ****
  • Chip Points: 1
  • Posts: 68
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #10 on: October 30, 2013, 06:58:52 AM »

Well for starters, its not my amp, nor do I play with gain on "10". It IS unrealistic to play this amp cranked like that. I went through and cleaned any pots contributing to any noise. I did get the amp back to a controllable state. Again it only feedsback with that squeal if the switch on the Ultra channel  is set to Ultra or the Lead channel is set to High Gain. Both functions put it into high gain territory which normally is associated with feedback. After cleaning the pots I was able to play with the gain around 3-4 oclock, channel volume around noon and using the master for overall volume before I got the nasty squeal.  I did have to stand at least 5-6 feet away to be controllable. Cleaning the pots was a major improvement. Perfectly quiet on any other setting. No results from the chopstick test. I put it back together and sending this one on its way.
Logged

Roly

  • Legendary
  • ******
  • Chip Points: 234
  • Posts: 1686
    • View Profile
    • Australian Valve Amps
Re: Peavey XXL squeal on Ultra channel
« Reply #11 on: October 30, 2013, 11:13:22 AM »

Did you try the "speaker in the other room" test Enzo suggested?

Quote from: markorock37
I did have to stand at least 5-6 feet away to be controllable.

My instant reaction to that is that it's your guitar pickup that is microphonic, not the amp.  If it's internal to the amp, how does standing six feet away make any difference???   ???
Logged
If you say theory and practice don't agree you haven't applied enough theory.

markorock37

  • Master SSGuitarist
  • ****
  • Chip Points: 1
  • Posts: 68
    • View Profile
Re: Peavey XXL squeal on Ultra channel
« Reply #12 on: October 30, 2013, 12:20:09 PM »

Did it to multiple guitars. It IS the amp. That's why its on its way out of my shop. Peavey should have never put this much gain on tap.
Logged
Pages: [1]   Go Up
 

* User Info
 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
* Recent Posts
DIY amp directions by Roly
[Today at 03:22:01 AM]


Two Channel Amp Design by Littlewyan
[September 29, 2014, 06:52:06 PM]


Orange Crush 10 - power yes, sounds sort of - input wont work by greybox
[September 29, 2014, 03:37:34 PM]


RANDALL TITAN SCHEMATICS by nofarewell
[September 27, 2014, 06:09:07 PM]


De-Soldering Station? by phatt
[September 26, 2014, 09:55:54 PM]

* Sponsors